Bug 43084 - fileutils don't like options
Summary: fileutils don't like options
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-31 17:32 UTC by John Strange
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 17:32:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Strange 2001-05-31 17:32:32 UTC
Description of Problem:

It seems ls/mv/cp all have similar problems, any attempt to specify filter 
such as ls *.mp3 spits out an error. 

How Reproducible:

I can repeat this on my system everytime, haven't checked any other RH7.1 
systems as I don't have any.

Steps to Reproduce:
1. ls *.mp3
2. cp *.mp3 /dir
3. mv *.mp3 /dir

Actual Results:

[root@kickstart-canvas mp3]# alias
alias l.='ls -d .[a-zA-Z]* --color=tty'
alias ll='ls -l --color=tty'
alias which='alias | /usr/bin/which --tty-only --read-alias --show-dot --
show-tilde'
[root@kickstart-canvas mp3]# ls *.mp3
ls: invalid option --  
Try `ls --help' for more information.
[root@kickstart-canvas mp3]# cp *.mp3 /tmp
cp: invalid option --  
Try `cp --help' for more information.
[root@kickstart-canvas mp3]# mv *.mp3 /tmp
mv: invalid option --  
Try `mv --help' for more information.
[root@kickstart-canvas mp3]# ls /tmp/mp3/*.mp3
/tmp/mp3/01- Destiny_s Child -- Independent Women (NEW SINGLE) Theme from 
Charlie_s Angel_mp3.mp3

-- [ cut out the rest ] --

/tmp/mp3/Wings of Honneamise - Prototype C.mp3
/tmp/mp3/Winter, Johnny - Forty-Four.mp3
/tmp/mp3/Zydeco-Poke Salad ANNIE(jO-EL sONNIER).mp3
[root@kickstart-canvas mp3]#

Expected Results:

I should get a file listing with just ls *.mp3 and not have to specify 
path.

Comment 1 Bernhard Rosenkraenzer 2001-05-31 17:41:11 UTC
That's because your filenames include "--" which ls, mv et al interpret as 
parameters, which is perfectly valid behavior.

What you want to do is

ls "*.mp3"



Comment 2 Bernhard Rosenkraenzer 2001-05-31 17:43:20 UTC
By the way, it's rather dangerous to post a file listing containing 
copyrighted mp3s to a publically visible bug tracking system. ;) You never 
know what sites RIAA fascists scan. ;)



Note You need to log in before you can comment on or make changes to this bug.