Bug 430846 - GtkAda-devel's gtkada.pc contains invalid alidir on 64-bit platforms
GtkAda-devel's gtkada.pc contains invalid alidir on 64-bit platforms
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: GtkAda (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 23:29 EST by Michel Alexandre Salim
Modified: 2008-02-13 10:11 EST (History)
0 users

See Also:
Fixed In Version: 2.10.0-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 10:10:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-01-29 23:29:00 EST
Description of problem:
I'm trying to build GNAT, and it uses pkg-config to find the compiler flags for
GtkAda. This contains -aO/usr/lib/gtkada, rather than -aO/usr/lib64/gtkada

Version-Release number of selected component (if applicable):
2.10.0-2

How reproducible:
Always

Steps to Reproduce:
1. pkg-config --cflags gtkada
  
Actual results:
Output contains -aO/usr/lib/gtkada

Expected results:
On 64-bit systems, should be -aO/usr/lib64/gtkada

Additional info:
Source URL is also invalid -- looks like AdaCore is no longer permitting
anonymous downloads. Sigh.
Comment 1 Michel Alexandre Salim 2008-01-30 12:53:08 EST
I rebuilt the version in Rawhide with the patch added. Going to build for F8 and
F7 and push them to testing.
Comment 2 Fedora Update System 2008-01-30 20:05:11 EST
GtkAda-2.10.0-4.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-01-30 20:05:35 EST
GtkAda-2.10.0-4.fc7 has been submitted as an update for Fedora 7
Comment 4 Gérard Milmeister 2008-02-06 10:09:41 EST
Thanks for the patch.
Comment 5 Fedora Update System 2008-02-13 10:10:02 EST
GtkAda-2.10.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-02-13 10:11:27 EST
GtkAda-2.10.0-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.