Bug 43087 - Installer crashes in progress bar code
Installer crashes in progress bar code
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 14:49 EDT by Scott Schmit
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 11:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Schmit 2001-05-31 14:49:35 EDT
Description of problem:
In a text mode install, the installer crashes while trying to update
the progress bar due to a divide by zero error. More frightening, however,
is that the python interpreter doesn't appear to always catch the
divide-by-zero, as on another occasion, the installer died in a signal 8.

How reproducible:
Sometimes - it sometimes works without crashing, other times very early.

Additional info:
Here's a python traceback.
Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in
doInstall
    (p, self.intf.messageWindow, pkgTimer))
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1588, in
instCallback
    intf.setPackageScale(amount, total)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 633, in
setPackageScale
    self.s.set(int(((amount * 1.0)/ total) * 100))
ZeroDivisionError: float division

Local variables in innermost frame:
total: 570924
amount: 350936
self: <text.InstallProgressWindow instance at 987df08>

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>

Let me know if there is any information you need that would help.
Comment 1 Brent Fox 2001-05-31 15:39:05 EDT
I think that you might have a bad cd.  Can you look on VC3 and VC4 and see if
there are any error messages?
Comment 2 Scott Schmit 2001-06-01 11:22:35 EDT
Nevermind, it was a configuration problem in the hardware.

Note You need to log in before you can comment on or make changes to this bug.