Bug 430902 - ypserv excessive vsize
ypserv excessive vsize
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypserv (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 09:12 EST by Adam Stokes
Modified: 2016-04-26 17:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch removing invalid ypdb_close call (489 bytes, patch)
2010-01-26 12:53 EST, Karel Klíč
no flags Details | Diff

  None (edit)
Comment 35 Issue Tracker 2008-05-07 02:37:11 EDT
*just some updates on things I have been doing tonight*

A couple other things.  I found that vmlib was showing up as 18tb:

root@lx-dgname06 11069# cat status
Name:   ypserv
[...]
VmLib:  18446744073709548224 kB

... which is similar to another issue I have been working w/ Citadel on:

https://bugzilla.redhat.com/show_bug.cgi?id=151597

I think this shows this is likely a 32/64b issue.

Also -- I went through the 5gig ypserv debug log, and grabbed all of the
maps used (mapname = "foo").  I then grabbed a count of each map.  It
looks like group.byname is by far being called the most in normal day to
day work:

auto_auto = 1802
auto.auto = 8429
auto_direct = 6669
auto_home = 16082
auto.home = 43575
auto_master = 6
ethers.byaddr = 4
group.bygid = 22155
group.byname = 61659361
hosts.byaddr = 32943   
hosts.byname = 19332
netgroup = 704491
netgroup.byuser = 315
netid.byname = 9868
passwd.adjunct.byname = 965
passwd.byname = 139162
passwd.byuid = 121242
protocols.byname = 5040
services.byname = 12637
services.byservicename = 32157

--chris



This event sent from IssueTracker by vanhoof 
 issue 140943
Comment 39 Denise Dumas 2008-06-10 10:22:26 EDT
Moving to 4.8 since no resolution appears imminent and 4.7 exception cycle is
closing down.
Comment 44 RHEL Product and Program Management 2008-10-31 12:39:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 45 Karel Klíč 2010-01-26 12:53:02 EST
Created attachment 386885 [details]
Patch removing invalid ypdb_close call

The symptoms of this bug seems to be very similar to rhbz#403621. It might be caused by the same flaw discovered in ypserv. 

The invalid code  "ypdb_close(NULL)" is called when an request for transferring
a new map comes to ypserv, and the map is not coming from trusted master
ypserver.

ypdb_close(ptr) calls gdbm_close(ptr), which expects a pointer to structure, and touches the structure without checking whether the pointer is NULL.
Comment 46 Karel Klíč 2010-01-27 07:51:36 EST
The attached patch was accepted by the upstream.
Comment 47 RHEL Product and Program Management 2010-10-22 14:53:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.