Bug 430920 - Curious i386 dependency when only x86_64 versions requested
Curious i386 dependency when only x86_64 versions requested
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lksctp-tools (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 12:00 EST by Bob Gustafson
Modified: 2008-02-05 11:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 11:34:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2008-01-30 12:00:41 EST
Description of problem:

In the package manager, I searched for all components having sctp in their
searchable text.

The results included
lksctp-tools-1.0.7.-2.fc8.i386 and
lksctp-tools-1.0.7.-2.fc8.x86_64

Since my machine is an x86_64, I selected only the components with that extension:
lksctp-tools-doc-1.0.7.-2.fc8.x86_64
lksctp-tools-1.0.7.-2.fc8.x86_64
lksctp-tools-devel-1.0.7.-2.fc8.x86_64
and
netembryo-0.0.5-1.fc8.x86_64

When the Package Manager checked for dependencies, it came up with:
lksctp-tools-1.0.7-2.fcb

The extension is not shown, so I really don't know if it is i386 or x86_64, but
since I selected the .x86_64 version, I seems as though Package Manager wants to
load the .i386 version.

This may be correct, but it may also be incorrect. Can both i386 and x86_64
versions exist peacefully together?

As yet, I have not clicked on 'Continue' to download all of the packages.

Version-Release number of selected component (if applicable):

  see above

How reproducible:

  Only did it once, so far.

Steps to Reproduce:
1. Applications -> Add/Remove Software
2. Select 'Search'
3. Search for 'sctp'
4. See above
  
Actual results:

  See above - Package Manager wants to load an i386 version (maybe) too.

Expected results:

  No additional dependencies, or libraries, etc with x86_64 extensions.

Additional info:
Comment 1 Bob Gustafson 2008-01-30 12:03:56 EST
I clicked 'Continue' and the installation proceeded Successfully..
Comment 2 Bob Gustafson 2008-01-30 12:09:43 EST
[root@hoho4 ~]# rpm -q lksctp-tools
lksctp-tools-1.0.7-2.fc8

Cannot tell if this is i386 or x86_64 version (or both)

tail /var/log/messages

Jan 30 10:55:03 hoho4 yum: Installed: lksctp-tools - 1.0.7-2.fc8.x86_64
Jan 30 10:55:03 hoho4 yum: Installed: lksctp-tools-doc - 1.0.7-2.fc8.x86_64
Jan 30 10:55:03 hoho4 yum: Installed: lksctp-tools-devel - 1.0.7-2.fc8.x86_64
Jan 30 10:55:04 hoho4 yum: Installed: netembryo - 0.0.5-1.fc8.x86_64

I don't see any i386 versions, so apparently yum did the right thing.
Comment 3 Zdenek Prikryl 2008-02-05 11:34:01 EST
Hello,
I followed your steps to reproduce this bug and I get same situation like you.
An additional dependency is caused by a package "netembryo". It seems, that a
GUI tries to resolves dependency and found that netembryo depends on
lksctp-tools. So this package is added as the dependency. But GUI dot notice,
that lksctp-tools was added already.

But installation ran over fine and no i386 packages were installed. If I tried
this in console with yum, everything worked fine and no i386 packages were
installed too.

So I'm closing this bug, since it isn't the bug in lksctp-tools dependencies.

Note You need to log in before you can comment on or make changes to this bug.