Bug 430921 - Constant "RX non-WEP frame, but expected encryption" messages
Constant "RX non-WEP frame, but expected encryption" messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 12:02 EST by Mary Ellen Foster
Modified: 2008-04-17 10:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.24.4-82.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 10:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2008-01-30 12:02:11 EST
Description of problem:
I have an iwl3945 wireless card that, for the most part, works great with Linux
and NetworkManager and so on. Recently, though -- unfortunately I don't know how
long -- when I have my laptop plugged into the network at work, the wireless
card is emitting a constant stream of messages. In /var/log/messages, it looks
like this:

Jan 28 09:05:40 floopy NetworkManager: <info>  Trying to start the supplicant...
Jan 28 09:05:40 floopy NetworkManager: <info>  (eth0) supplicant interface is
now in state 1 (from 0).
Jan 28 09:05:40 floopy NetworkManager: <info>  (wlan0) supplicant manager is now
in state 1 (from 0).
Jan 28 09:05:40 floopy NetworkManager: <info>  (eth0) supplicant interface is
now in state 2 (from 1).
Jan 28 09:05:40 floopy NetworkManager: <info>  (wlan0) supplicant interface is
now in state 2 (from 1).
Jan 28 09:06:00 floopy kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jan 28 09:06:05 floopy kernel: printk: 2 messages suppressed.
Jan 28 09:06:11 floopy kernel: printk: 27 messages suppressed.
Jan 28 09:06:16 floopy kernel: printk: 35 messages suppressed.
Jan 28 09:06:20 floopy kernel: printk: 29 messages suppressed.
Jan 28 09:06:25 floopy kernel: printk: 64 messages suppressed.
[ ... ]

In the output of dmesg, there's a bit more information:
wlan0: RX non-WEP frame, but expected encryption
printk: 42 messages suppressed.
wlan0: RX non-WEP frame, but expected encryption
printk: 71 messages suppressed.
wlan0: RX non-WEP frame, but expected encryption
printk: 138 messages suppressed.
wlan0: RX non-WEP frame, but expected encryption
printk: 109 messages suppressed.
wlan0: RX non-WEP frame, but expected encryption
eth0: no IPv6 routers present
printk: 60 messages suppressed.
wlan0: RX non-WEP frame, but expected encryption
printk: 64 messages suppressed.
[ ... ]

This flood of messages stops as soon as I disable wireless through
NetworkManager. It only happens at work, where there are a couple of wireless
networks that I don't use; wireless works great at home and other places that
I've used it.


Version-Release number of selected component (if applicable):
kernel-2.6.23.14-115.fc8 (but it's been happening for a while)

How reproducible:
Always

Steps to Reproduce:
1. Boot computer at work with NetworkManager enabled
2. Connect to wired network
  
Actual results:
Constant flood of kernel errors until I disable wireless

Expected results:
Wireless to shut up because I'm not even using it! :)
Comment 1 Mary Ellen Foster 2008-01-30 12:26:41 EST
One additional note: it seems that this problem *may* have started when I
installed NetworkManager-0.7.0-0.6.7.svn3204. Since I can stop the problem from
happening by disabling wireless in NM, I'm reassigning the bug (sorry for the
churn).
Comment 2 Dan Williams 2008-04-10 12:45:45 EDT
Thoughts John?  Shouldn't be spewing messages, but I'm unclear of what sort of
frames mac80211 is expecting here that would cause it to output the message.  NM
should not be touching the wireless device at all (in the version the reporter
mentions there is no multiple active device support) but perhaps an 'iwconfig
wlan0' would be useful here.
Comment 3 Mary Ellen Foster 2008-04-14 05:52:34 EDT
NB: I've been away from this particular location for a couple of months. But I'm
now back here, and the message spew is still happening. If you need me to test
anything, I'm willing.
Comment 4 John W. Linville 2008-04-15 17:34:16 EDT
The build here has a patch that removes the message in question:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=46311

When the build complete, could you give it a try and confirm that the message 
is gone?  Thanks!
Comment 5 Mary Ellen Foster 2008-04-16 05:43:56 EDT
I'll try the build shortly (need to reboot). For now, here's the output of
/sbin/iwconfig wlan0 under the current kernel (while the messages are spewing
into the log):

wlan0     IEEE 802.11  ESSID:"central"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:16:35:9D:4B:F3
          Bit Rate=54 Mb/s   Tx-Power=15 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Link Quality=80/100  Signal level=-54 dBm  Noise level=-41 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

"central" is the wireless network that I'm not actually using. I have connected
to it in the past, I think, but these days I'm always plugged into eth0 and
that's what I actually use.

If I disable wireless in NM, iwconfig produces the following:

wlan0     IEEE 802.11  ESSID:"central"
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated
          Tx-Power=15 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 6 Mary Ellen Foster 2008-04-17 04:04:10 EDT
(In reply to comment #4)
> The build here has a patch that removes the message in question:
> 
>    http://koji.fedoraproject.org/koji/buildinfo?buildID=46311
> 
> When the build complete, could you give it a try and confirm that the message 
> is gone?  Thanks!

Yes, the message is indeed gone with this kernel. Yay! :)

Note You need to log in before you can comment on or make changes to this bug.