Bug 430926 - not able to add bridged network card via addhardware
not able to add bridged network card via addhardware
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On: 392881
Blocks: 447412
  Show dependency treegraph
 
Reported: 2008-01-30 12:18 EST by Cole Robinson
Modified: 2009-12-14 16:17 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2008-01-30 12:18:27 EST
+++ This bug was initially created as a clone of Bug #392881 +++

Description of problem:
I'm not able to add virtual bridged network card. Traceback pops up.


Version-Release number of selected component (if applicable):
virt-manager-0.5.2-2.fc8
libvirt-0.3.3-2.fc8


How reproducible:
always


Steps to Reproduce:
1. # brctl addbr br0
2. # brctl addif br0 eth0
3. Details > Add network card > Shared physical device > select only one 
possible there


Actual results:
GUI shows traceback, this traceback is also on the command line, virt-manager 
starts to generate also this "libvir: QEMU chyba : TAP bridge path 'eth0 
(Bridge br0)' is too long" on the command line.


Expected results:
Virtual card is created


Additional info:

Traceback in the GUI:

Unable to complete install '<class 'libvirt.libvirtError'> virDomainDefineXML() 
failed TAP bridge path 'eth0 (Bridge br0)' is too long
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 530, in 
add_device
    self.vm.add_device(xml)
  File "/usr/share/virt-manager/virtManager/domain.py", line 690, in add_device
    self.get_connection().define_domain(newxml)
  File "/usr/share/virt-manager/virtManager/connection.py", line 445, in 
define_domain
    self.vmm.defineXML(xml)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 589, in defineXML
    if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self)
libvirtError: virDomainDefineXML() failed TAP bridge path 'eth0 (Bridge br0)' 
is too long
'

Traceback in the command line:

Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve 
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value 
"((GString*) 0x12bb6e0)" of type `GString'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 649, in 
change_graphics_type
    graphics = self.get_config_graphics()
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 279, in 
get_config_graphics
    return type.get_model().get_value(type.get_active_iter(), 1)
TypeError: iter must be a GtkTreeIter
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 649, in 
change_graphics_type
    graphics = self.get_config_graphics()
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 279, in 
get_config_graphics
    return type.get_model().get_value(type.get_active_iter(), 1)
TypeError: iter must be a GtkTreeIter
libvir: QEMU chyba : TAP bridge path 'eth0 (Bridge br0)' is too long
libvir: QEMU chyba : TAP bridge path 'eth0 (Bridge br0)' is too long
libvir: QEMU chyba : TAP bridge path 'eth0 (Bridge br0)' is too long

I'm not sure that this is not my fault (bad bridge set-up), but I think virt-
manager should provide some error message instead of the traceback.

-- Additional comment from berrange@redhat.com on 2008-01-11 00:28 EST --
This was a bug in virt-manager - it was getting the drop down list label vs
bridge device name mixed up :-( Will be fixed in next update


-- Additional comment from updates@fedoraproject.org on 2008-01-11 17:23 EST --
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If
problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'

-- Additional comment from updates@fedoraproject.org on 2008-01-22 10:52 EST --
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If
problems still persist, please make note of it in this bug report.

-- Additional comment from crobinso@redhat.com on 2008-01-30 11:03 EST --
Unfortunately this bug existed in two places, and we only fixed the one for
creating a guest. This one applies to the addhardware wizard. Reopening.
Comment 1 Cole Robinson 2008-01-30 12:37:29 EST
This is a quick fix that has been identically tested in similar code elsewhere
in virt-manager, and is something we should pull in for 5.2 since it completely
blocks adding a bridged network device to an existing guest via virt-manager.

Fix is now upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=dbd25721f588
Comment 2 RHEL Product and Program Management 2008-01-30 12:45:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Cole Robinson 2008-02-05 11:00:00 EST
This fix is available in the latest virt-manager package:

$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-2.el5                  dist-5E-qu-candidate  crobinso
Comment 7 errata-xmlrpc 2008-05-21 13:28:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html

Note You need to log in before you can comment on or make changes to this bug.