Bug 430940 - [RHEL5 U2] Kernel-xen reports "failed to set up cpufreq notifier" while booting on some systems
[RHEL5 U2] Kernel-xen reports "failed to set up cpufreq notifier" while booti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bhavna Sarathy
Martin Jenner
http://rhts.lab.boston.redhat.com/tes...
: Regression
Depends On:
Blocks: 253746
  Show dependency treegraph
 
Reported: 2008-01-30 13:40 EST by Jeff Burke
Modified: 2009-06-19 22:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-01-30 13:40:28 EST
Description of problem:
 While booting specific systems the kernel reports an failure "failed to set up
cpufreq notifier"
Host it was seen on:
hp-dl585g2-01.rhts.boston.redhat.com
es7000-01.lab.boston.redhat.com

Version-Release number of selected component (if applicable):
 2.6.18-76

How reproducible:
 Always

Steps to Reproduce:
1. Install RHEL5-U1 on any of the above hosts.
2. Install the xen kernel and reboot
  
Actual results:
<snip>

ENABLING IO-APIC IRQs
SMP alternatives: switching to SMP code
Initializing CPU#1
Initializing CPU#2
Initializing CPU#3
Initializing CPU#4
Initializing CPU#5
Initializing CPU#6
Brought up 8 CPUs
sizeof(vma)=88 bytes
sizeof(page)=32 bytes
sizeof(inode)=340 bytes
sizeof(dentry)=136 bytes
sizeof(ext3inode)=492 bytes
sizeof(buffer_head)=52 bytes
sizeof(skbuff)=172 bytes
Initializing CPU#7
migration_cost=491
checking if image is initramfs... it is
Freeing initrd memory: 6630k freed
failed to set up cpufreq notifier
Grant table initialized
NET: Registered protocol family 16
No dock devices found.
ACPI: bus type pci registered
PCI: Using configuration type 1
Setting up standard PCI resources
Allocating PCI resources starting at 88000000 (gap: 80000000:60000000)
ACPI (exconfig-0456): Dynamic SSDT Load - OemId [HP    ] OemTableId [PNOWSSDT]
[20060707]
ACPI: Interpreter enabled
</snip>
Expected results:


Additional info:
Comment 5 RHEL Product and Program Management 2008-02-06 16:49:14 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Don Zickus 2008-02-08 15:35:24 EST
This is the function that fails:

static int __init cpufreq_time_setup(void)
{
>>>>>>> if (!cpufreq_register_notifier(&time_cpufreq_notifier_block,
                        CPUFREQ_TRANSITION_NOTIFIER)) {
                printk(KERN_ERR "failed to set up cpufreq notifier\n");
                return -ENODEV;
        }
        return 0;
}

cpufreq_register_notifier will return 0 on success, which means this logic seems
reversed.  I assume removing the '!' will fix the issue.
Comment 7 Bhavna Sarathy 2008-02-11 17:03:54 EST
Does this fail on all systems or just a few?   If the logic is reversed it
should fail on all systems.   I didn't think I saw the issue on Anaheim
Barcelona system, but I'll check again.
Comment 8 Don Zickus 2008-02-11 17:53:35 EST
RHTS shows every xen system on x86 arch fails.
Comment 9 Bhavna Sarathy 2008-02-12 10:33:31 EST
Yes, I see the error with -80 and the logic is incorrect.   This function must
have been introduced recently as I have some Xen test kernels where this wasn't
an issue.
Comment 10 Don Zickus 2008-02-12 11:03:30 EST
This function came as is with Rik's changes to cpufreq on xen.  I put this patch
in back in middle of December in -62.el5.  So it should have been broken since then.
Comment 11 Bhavna Sarathy 2008-02-12 12:27:50 EST
Fixed Rik's broken patch; patch posted on Feb 12 to RHML and virt-list
Comment 12 Russell Doty 2008-02-12 17:11:58 EST
Based on comment 8, shouldn't this be a high or urgent priority?
Comment 15 Bhavna Sarathy 2008-03-07 11:58:09 EST
Sure.
Comment 16 Bhavna Sarathy 2008-03-07 11:58:59 EST
Russ, could you please add this to the AMD tracker, so I can keep this in my radar?
Comment 17 Don Zickus 2008-03-12 15:41:18 EDT
in kernel-$NEW_VER
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 18 Don Zickus 2008-03-12 15:59:55 EDT
in kernel-2.6.18-85.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 20 Frank Arnold 2008-04-14 15:00:53 EDT
We saw this with Beta. All of our systems with snap3 or snap4 installs don't
show this anymore.
Comment 22 errata-xmlrpc 2008-05-21 11:08:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.