Bug 430950 - setroubleshoot recommended actions should escape special characters in path names or file names
setroubleshoot recommended actions should escape special characters in path n...
Status: CLOSED DUPLICATE of bug 416351
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: setroubleshoot (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 14:14 EST by Jeff Needle
Modified: 2008-01-30 15:26 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 15:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-01-30 14:14:59 EST
Description of problem:

Got a lovely message from setroubleshoot telling me exactly how to fix a
problem, as follows:

The following command will allow this access:
chcon -R -t samba_share_t /home/jneedle/directory with space/filename

Being an incredibly lazy sysadmin, I of course just cut and pasted that to the
command line.  Of course, it failed.  Maybe we should put the path in quotes or
escape special characters so this is cut-and-pasteable, making it even easier
for zombie sysadmins like myself to simply cut and paste these recommendations.

Version-Release number of selected component (if applicable):
setroubleshoot-1.8.11-4.el5.noarch (probably affects all releases)
Comment 1 John Dennis 2008-01-30 15:26:32 EST
Good point Jeff, thank you. This problem has already been reported in bug
#416351, closing as a dup.

BTW, rather than escaping the characters as suggested in bug #416351 I prefer
your suggestion of quoting the arguments.

*** This bug has been marked as a duplicate of 416351 ***

Note You need to log in before you can comment on or make changes to this bug.