Bug 430961 - vpnc-helper doesn't pass arguments
vpnc-helper doesn't pass arguments
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 14:53 EST by Daniel Malmgren
Modified: 2008-01-30 16:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 16:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2008-01-30 14:53:47 EST
Description of problem:
Noticed that when I run vpnc as an ordinary user it completely ignores all
arguments passed.

Version-Release number of selected component (if applicable):
vpnc-consoleuser-0.5.1-2.fc8

How reproducible:
100%

Steps to Reproduce:
1. As an ordinary user, run vpnc with some arguments
  
Actual results:
The arguments are ignored.

Expected results:
Obvious.

Additional info:
Adding a simple $@ to the second line of /usr/sbin/vpnc-helper fixes this. Or is
this somehow a bad idea?
Comment 1 Tomas Mraz 2008-01-30 16:38:52 EST
Yes, this is actually very bad idea, because you can make to run any script
under root priviledges from regular user account.

Note You need to log in before you can comment on or make changes to this bug.