Bug 430988 - Firefox asks to be the default browser
Summary: Firefox asks to be the default browser
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-30 22:48 UTC by Julian Sikorski
Modified: 2008-02-08 15:29 UTC (History)
0 users

Fixed In Version: 3.0-0.beta2.16.nightly20080206.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 15:29:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julian Sikorski 2008-01-30 22:48:45 UTC
Description of problem:
Although Firefox is set as default browser in System -> Preferences -> Personal
-> Preferred Applications, it asks to be the default browser every time it is
run. What is the issue, is that it sets the following value:
/usr/lib64/firefox-3.0b3pre/firefox "%s"
which causes the plugins to be not detected

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta2.12.nightly20080121.fc9.x86_64
xulrunner-1.9-0.beta2.14.nightly20080121.fc9.x86_64
nss-3.11.99.3-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install the said version of firefox
2. Run it using htmlview
3. Answer yes to the question about making firefox the default
  
Actual results:
A non-working command is set

Expected results:
A working command is set, or even better, firefox respects the gnome settings

Additional info:
This can be related to a recent xulrunner or nss update, since I remember
everything was working fine a while ago. I am running Fedora 8 if that matters,
only firefox and required deps are from rawhide.

Comment 1 Christopher Aillon 2008-01-31 19:54:42 UTC
I just committed something which ought to fix this next time we do a build (in
the next few days).


Note You need to log in before you can comment on or make changes to this bug.