Bug 430992 - Slow installation when using serial console
Summary: Slow installation when using serial console
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-30 23:07 UTC by gman
Modified: 2008-04-18 16:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 16:04:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gman 2008-01-30 23:07:03 UTC
Description of problem:

When I install and have the output use the serial port for console
(console=ttyS0,9600) the install slows cause its trying to display all the
screen changes during the package installation dialog. When I do the same
install without serial console , it finishes the install several times faster. 

Is there a way to decrease the amount of screen redraws/changes when doing a
serial console install? I would increase the baudrate but it is not an option I
have.


Version-Release number of selected component (if applicable):


How reproducible:

Notice the difference for every install I do.

Steps to Reproduce:
Setup console redirection with console=ttyS0,9600
start the installation

Comment 1 Lubomir Kundrak 2008-03-08 21:33:00 UTC
I guess you can use "cmdline" instead of "text" installation?

Comment 2 gman 2008-03-14 22:21:08 UTC
I still see the same thing. 

Comment 3 Joel Andres Granados 2008-04-18 16:04:03 UTC
The reason that the installation is slow is because of the 9600 in the console
command.  If you increase the baud rate anaconda draws the screens much faster
(if you use 19200 its not even noticeable).  AFAIK, its not that anaconda isn't
quick about painting the screens, its that anaconda receives the info at a slow
rate.  Try 4800 and it will be slower :)


Note You need to log in before you can comment on or make changes to this bug.