This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 431004 - [RHEL5-U2] Kernel e1000e: 0000:00:1c.0: eth0: Unable to allocate MSI interrupt Error: -1
[RHEL5-U2] Kernel e1000e: 0000:00:1c.0: eth0: Unable to allocate MSI interrup...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
http://rhts.lab.boston.redhat.com/cgi...
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 20:03 EST by Jeff Burke
Modified: 2014-06-29 18:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
e1000e-irq-minimize.patch (1.04 KB, patch)
2008-01-31 18:08 EST, Andy Gospodarek
no flags Details | Diff
e1000e-irq-minimize.patch (1.04 KB, patch)
2008-01-31 18:10 EST, Andy Gospodarek
no flags Details | Diff

  None (edit)
Description Jeff Burke 2008-01-30 20:03:55 EST
Description of problem:
 While booting the 2.6.18-76.el5 kernel the e1000e reports an error:
0000:00:1c.0: eth0: Unable to allocate MSI interrupt Error: -1

Version-Release number of selected component (if applicable):
 2.6.18-76.el5

How reproducible:
 Always

Several system in RHTS use this driver:
ixen-01.rhts.boston.redhat.com
ixen-02.rhts.boston.redhat.com
  
Actual results:
01:00.0 Ethernet controller: Intel Corporation 82573E Gigabit Ethernet
Controller (Copper) (rev 03)

Checking module information e1000e:
Intel(R) PRO/1000 Network Driver 0.2.0

Expected results:
 System should not report errors during normal boot operations

Additional info:
 I have not seen any adverse affect as a result of the Error message being printed.
Comment 1 RHEL Product and Program Management 2008-01-31 13:47:13 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Andy Gospodarek 2008-01-31 14:13:23 EST
This hardware is one of the ones that switched from e1000 to e1000e on this
update.  I tried to login to ixen-01.rhts.boston.redhat.com, but cannot and
ixen-02.rhts.boston.redhat.com seems to be running an 2.6.24-based rt kernel (so
still using e1000 for some reason).  Do you know if these systems were not able
to use MSI for handling interrupts when using e1000e?  Can I reboot ixen-02 and
try it out?
Comment 3 Andy Gospodarek 2008-01-31 14:55:18 EST
The message that shows up is simply to inform the user that MSI doesn't work on
this system.  The older e1000 driver didn't print a message when MSI didn't
work.  I've reserved ixen-01 from rhts and will test 5.1 and 5.2beta kernels to
make sure they operate the same (both with INTx mode rather than one with MSI
and one without).
Comment 4 Andy Gospodarek 2008-01-31 15:33:22 EST
Looks like everything is fine on the 2.6.18-53 and a 2.6.18-75-based kernel. 
They both have MSI enabled on the NIC (at least accoring to /proc/interrupts). 
There really isn't any difference in the code that initializes MSI between the
e1000 and e1000e driver except for the extra error message if MSI fails in e1000e.

I'm going to check and see if there is a difference between 53xen and 75xen just
to be sure these kernels are behaving the same.


 
Comment 5 Andy Gospodarek 2008-01-31 15:54:37 EST
[root@ixen-01 ~]# uname -a
Linux ixen-01.rhts.boston.redhat.com 2.6.18-53.el5xen #1 SMP Wed Oct 10 16:48:44
EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@ixen-01 ~]# cat /proc/interrupts
           CPU0              CPU1
  1:          8          0        Phys-irq  i8042
  6:          5          0        Phys-irq  floppy
  7:          0          0        Phys-irq  parport0
  8:          0          0        Phys-irq  rtc
  9:          0          0        Phys-irq  acpi
 12:        103          0        Phys-irq  i8042
 17:          0          0        Phys-irq  uhci_hcd:usb3
 18:      20048          0        Phys-irq  uhci_hcd:usb2, libata
 19:       1175        140        Phys-irq  uhci_hcd:usb4, eth0
 20:          0          0        Phys-irq  uhci_hcd:usb1
 21:        148          0        Phys-irq  HDA Intel
256:      14217          0     Dynamic-irq  timer0
257:       2807          0     Dynamic-irq  resched0
258:         42          0     Dynamic-irq  callfunc0
259:          0       3377     Dynamic-irq  resched1
260:          0         94     Dynamic-irq  callfunc1
261:          0       6783     Dynamic-irq  timer1
262:          0          0     Dynamic-irq  xenbus
263:         61          0     Dynamic-irq  console
NMI:          0          0
LOC:          0          0
ERR:          0
MIS:          0

# uname -a
Linux ixen-01.rhts.boston.redhat.com 2.6.18-75.el5.gtest.37xen #1 SMP Tue Jan 29
23:13:12 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
[root@ixen-01 ~]# cat /proc/interrupts
           CPU0              CPU1
  1:          8          0        Phys-irq  i8042
  6:          5          0        Phys-irq  floppy
  7:          0          0        Phys-irq  parport0
  8:          0          0        Phys-irq  rtc
  9:          0          0        Phys-irq  acpi
 12:        103          0        Phys-irq  i8042
 17:          0          0        Phys-irq  uhci_hcd:usb3
 18:       7315          0        Phys-irq  uhci_hcd:usb2, libata
 19:        134        141        Phys-irq  uhci_hcd:usb4, eth0
 20:          0          0        Phys-irq  uhci_hcd:usb1
 21:        148          0        Phys-irq  HDA Intel
256:       6737          0     Dynamic-irq  timer0
257:       1747          0     Dynamic-irq  resched0
258:         44          0     Dynamic-irq  callfunc0
259:          0       2375     Dynamic-irq  resched1
260:          0         93     Dynamic-irq  callfunc1
261:          0       4993     Dynamic-irq  timer1
262:          0          0     Dynamic-irq  xenbus
263:         23          0     Dynamic-irq  console
NMI:          0          0
LOC:          0          0
ERR:          0
MIS:          0

No real difference between the 2 here.  

As long as it can be confirmed that Xen kernels don't allow the traditional use
of MSI interrupts (at least as far as the running kernel is concerned) then this
should be closed as NOTABUG.
Comment 6 Andy Gospodarek 2008-01-31 18:08:09 EST
Created attachment 293662 [details]
e1000e-irq-minimize.patch

I posted the following upstream and when we get some confirmation from one of
the 'xen folks' that not having MSI interrupts is expected feel free to
transfer this back to me and I'll take it and post the patch.
Comment 7 Andy Gospodarek 2008-01-31 18:10:05 EST
Created attachment 293663 [details]
e1000e-irq-minimize.patch

I've got patch issues.... :-)
Comment 8 Andy Gospodarek 2008-02-01 14:33:41 EST
Anyone familiar with Xen and interrupts want to make a statement regarding
comment #5?
Comment 9 Andy Gospodarek 2008-02-04 11:58:12 EST
My test kernels have been updated to include a patch for this bugzilla.

http://people.redhat.com/agospoda/#rhel5

Please test them and report back your results.
Comment 14 Don Zickus 2008-02-08 15:30:38 EST
in 2.6.18-79.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 16 Mike Gahagan 2008-04-28 16:32:55 EDT
confirmed fix is in the -90 .el5 kernel
Comment 18 errata-xmlrpc 2008-05-21 11:08:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.