Bug 431012 - Openoffice prints n-up incorrectly
Openoffice prints n-up incorrectly
Status: CLOSED DUPLICATE of bug 422661
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 22:44 EST by Austin Acton
Modified: 2008-01-31 03:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 03:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample printed directly from oo.o (66.43 KB, image/png)
2008-01-30 22:49 EST, Austin Acton
no flags Details
PDF viewed and printed in Evince (96.00 KB, image/png)
2008-01-30 22:49 EST, Austin Acton
no flags Details

  None (edit)
Description Austin Acton 2008-01-30 22:44:25 EST
Printing multiple pages per page with openoffice results in the incorrect order
of slides.  To reproduce: open a presentation in Impress, to do print, set
slides per page to 6, select print.  Rather than 12,34,56 slides show up 41,52,63.

Proof that this is openoffice's fault rather than gnome-print.  In Impress, save
same document as regular PDF file, one slide per page.  Open PDF file in Evince.
 Go to print, choose 6 pages per page, select print.  Output is in the expected
order.
Comment 1 Austin Acton 2008-01-30 22:49:00 EST
Created attachment 293535 [details]
sample printed directly from oo.o
Comment 2 Austin Acton 2008-01-30 22:49:44 EST
Created attachment 293536 [details]
PDF viewed and printed in Evince
Comment 3 Austin Acton 2008-01-30 22:50:22 EST
As an aside, you'll also notice that the margins are significantly different.
Comment 4 Caolan McNamara 2008-01-31 03:09:57 EST
As in you get 1,2,3 down the right, and 4,5,6 down the left. I believe that is
the same as bug 422661

The landscaping of each slide confuses the cups n-up thing as cups can't find
the "human designated rotation" of each slide to work it out. Where the solution
I have is to detect we're targeting n-ups and rotate into portrait mode but with
a landscape sized page size which lets cups do-the-right-thing.

I suspect that if you used print to .ps from OOo and not pdf and opened that in
evince that the 6 pages per page may then give the same results as direct from OOo.

*** This bug has been marked as a duplicate of 422661 ***

Note You need to log in before you can comment on or make changes to this bug.