Bug 431050 - emacs hangs the whole desktop when I use alt-tab
emacs hangs the whole desktop when I use alt-tab
Status: CLOSED DUPLICATE of bug 224611
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-31 08:40 EST by Kjartan Maraas
Modified: 2008-04-19 12:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-19 12:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
.emacs file (453 bytes, application/octet-stream)
2008-01-31 08:41 EST, Kjartan Maraas
no flags Details

  None (edit)
Description Kjartan Maraas 2008-01-31 08:40:21 EST
Description of problem:

When I use alt-tab to switch to another app from emacs my whole desktop hangs. I
have to go to the console and kill emacs to get my desktop back. I think this is
related to my personal account so it would be nice to get some information on
what files in $HOME affects emacs' behaviour.

Attaching the obvious ones

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Kjartan Maraas 2008-01-31 08:41:07 EST
Created attachment 293580 [details]
.emacs file
Comment 2 Robin Norwood 2008-02-08 14:34:21 EST
I get the same thing, even after moving aside my .emacs file.

This is with emacs-22.1.50-3.fc9.i386

Updating priority and severity, since this makes emacs completely unusable for
me in rawhide.
Comment 3 Kjartan Maraas 2008-02-10 18:55:16 EST
This resolved itself for me now. I can't reproduce this with current rawhide.
Robin, do you see the same?
Comment 4 Robin Norwood 2008-02-11 13:01:46 EST
No, I still have the same problem.  It may not be directly emacs-related either,
because downgrading to F-8's emacs doesn't fix it either.
Comment 5 Kjartan Maraas 2008-02-11 16:16:44 EST
it got fixed in a recent rawhide update for me. not sure what fixed it though :-/
Comment 6 Jim Treadway 2008-02-29 13:28:50 EST
I think this might be related to bug #224611.
Comment 7 Chip Coldwell 2008-02-29 13:32:10 EST
(In reply to comment #6)
> I think this might be related to bug #224611.

The easy way to find out is to turn off atk:

System->Preferences->Personal->Assitive Technology Preferences

make sure it's turned off.

Comment 8 Kjartan Maraas 2008-04-19 11:56:39 EDT
Yeah, it only happens when a11y is activated. Shouldn't this be a blocker for f9?
Comment 9 Kjartan Maraas 2008-04-19 12:02:02 EDT
Marking as duplicate.

*** This bug has been marked as a duplicate of 224611 ***

Note You need to log in before you can comment on or make changes to this bug.