Bug 431076 - unable to make directories in union
unable to make directories in union
Product: Fedora
Classification: Fedora
Component: funionfs (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-31 11:28 EST by Mike McLean
Modified: 2012-02-20 03:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 795310 (view as bug list)
Last Closed: 2009-01-09 00:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2008-01-31 11:28:23 EST
I tried following the directions at:

I'm using:

I'm able to mount the unionfs and make some modifications, but a number of
things fail, notably mkdir.

I'm setting things up with:
# mkdir /mnt/test-base /mnt/test-overlay /mnt/test-union
# funionfs -o dirs=/mnt/test-base=RO:/mnt/test-overlay  -o allow_other NONE

(I've also tried with the mount syntax, and gotten the same behavior). Perhaps
I'm missing something. If so, please enlighten me.

I can create a new file by writing to it:
# cd /mnt/test-union/
# echo hello >new_file
# cat new_file 

but other things fail:
# mkdir /mnt/test-union/new_dir
mkdir: cannot create directory `/mnt/test-union/new_dir': No such file or directory

oddly enough, this also fails for an existing file (nomatter which underlying fs
it lives on):
# echo hello >/mnt/test-union/some_file
-bash: /mnt/test-union/some_file: File exists
It seems to be the O_TRUNC flag that causes the error.
# python -c 'import os; fd = os.open("new_file", os.O_CREAT|os.O_RDWR|os.O_TRUNC)'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
# python -c 'import os; fd = os.open("new_file", os.O_CREAT|os.O_RDWR)'
Comment 1 STEPHAN Gael 2008-06-13 11:02:21 EDT
Adding myself to cc as i can't find any union filesystem working in f9 at the
moment and i badly need one..
Comment 2 Mike McLean 2008-06-13 16:23:43 EDT
Stephan - I haven't tried with f9 yet, but I was able to apply the unionfs patch
(non-FUSE) to the f8 kernel and get things working.

Comment 3 Bernd Schubert 2008-06-26 17:57:02 EDT
Stephan, could you try to use unionfs-fuse? Like funionfs it is fuse based, but very actively 
maintained. If you ever have problem with it, please report to the mailing list.

Comment 4 Bug Zapper 2008-11-26 04:39:15 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-01-09 00:53:27 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 6 Leif Gruenwoldt 2010-12-02 10:57:17 EST
I'm experiencing this problem on Fedora 14.
Comment 7 Simon B 2010-12-06 07:31:34 EST
(In reply to comment #6)
> I'm experiencing this problem on Fedora 14.

me as well!
Comment 8 Dmitry S. Makovey 2012-02-20 03:19:55 EST
F17 has the same problem with no alternatives in sight

Note You need to log in before you can comment on or make changes to this bug.