Bug 431089 - ipa_webgui doesn't start due to premissions error on /var/log/ipa_error.log
Summary: ipa_webgui doesn't start due to premissions error on /var/log/ipa_error.log
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise IPA
Classification: Retired
Component: ipa-server   
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: freeipa10 429034 435119
TreeView+ depends on / blocked
 
Reported: 2008-01-31 18:21 UTC by Michael Gregg
Modified: 2015-01-21 15:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 15:21:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
create the log file in the %post script (2.43 KB, patch)
2008-01-31 19:20 UTC, Rob Crittenden
no flags Details | Diff

Description Michael Gregg 2008-01-31 18:21:46 UTC
Description of problem:
ipa_webgui doesn't start due to premissions error on /var/log/ipa_error.log. 
This particullar instance was observed while running ipa-server-install

Version-Release number of selected component (if applicable):
Build from 1-31-08:
http://apoc.dsdev.sjc.redhat.com/tet/results/FC7/i386/2008-01-31_03_01-build/
ipa.repo

How reproducible:


Steps to Reproduce:
1.Install ipa-server packages with named and caching named server
2. install IPA with /usr/sbin/ipa-server-install -U --
hostname=ipaqavm.dsqa.sjc2.redhat.com -r DSQA.SJC2.REDHAT.COM -p pw -P pw -a pw 
--setup-bind -u admin -d
  
Actual results:
root        : INFO     Shutting down ipa_webgui: [FAILED]
Starting ipa_webgui: failed to start web gui: [Errno 13] Permission denied: '/
var/log/ipa_error.log'
[FAILED]
root        : INFO     ERROR:root:failed to start web gui: [Errno 13] 
Permission denied: '/var/log/ipa_error.log'
  File "/usr/sbin/ipa_webgui", line 147, in <module>

Expected results:
ipa-server-install to work and ipa-webgui to run

Comment 1 Rob Crittenden 2008-01-31 19:20:54 UTC
Created attachment 293628 [details]
create the log file in the %post script

Comment 2 Rob Crittenden 2008-02-01 15:42:20 UTC
Committed in changeset 617

Comment 3 Michael Gregg 2008-02-02 01:14:43 UTC
re-ran test after patch

Result:
root        : INFO     Shutting down ipa_webgui: [FAILED]
Starting ipa_webgui: [  OK  ]

run aginst:
http://apoc.dsdev.sjc.redhat.com/tet/results/FC7/i386/2008-02-01_16_03-build/dist

Comment 7 Martin Kosek 2015-01-21 15:21:47 UTC
"Red Hat Enterprise IPA" product is not used or maintained. As this bug has a VERIFIED or RELEASE_PENDING status, it can be safely closed.

For further requests for the Red Hat Enterprise Linux Identity Management, please consider filing a Bug to RHEL "ipa" component.


Note You need to log in before you can comment on or make changes to this bug.