Bug 431107 - halt script does not work with upstart
halt script does not work with upstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: upstart
  Show dependency treegraph
 
Reported: 2008-01-31 15:12 EST by Bill Nottingham
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 19:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check runlevel in halt/reboot, set --force accordingly (1.15 KB, patch)
2008-02-15 18:03 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2008-01-31 15:12:37 EST
If you attempt to shutdown/reboot/halt, the halt script just ends up looping
endlessly.

initscripts-8.62-1
Comment 1 Casey Dahlin 2008-02-11 16:29:25 EST
Have we decided if patching killall5 will work for this?
Comment 2 Bill Nottingham 2008-02-14 16:44:03 EST
It doesn't loop any more, but it doesn't do the right thing either.
Comment 3 Bill Nottingham 2008-02-15 18:02:20 EST
This is an upstart bug, at least as far as SysV compatibility goes.

halt/reboot under SysV check the runlevel when they run - if it's 0 or 6
(reboot/halt), then 'force' is implied. upstart's versions don't have that code,
so they just call shutdown again, which starts the loop/hangs.

Patch attached momentarily.
Comment 4 Bill Nottingham 2008-02-15 18:03:27 EST
Created attachment 295051 [details]
check runlevel in halt/reboot, set --force accordingly
Comment 5 Casey Dahlin 2008-02-15 22:47:16 EST
Do we want to apply just this patch to upstart, or both this patch and the
no-kill-init sysv patch?

I'll roll this in to the rpm tonight. Scott, care to weigh in?
Comment 6 Scott James Remnant 2008-02-16 06:19:36 EST
That patch is definitely the right solution ;)

It didn't affect us because our sysv scripts called halt/reboot with --force anyway
Comment 7 Casey Dahlin 2008-02-16 19:22:10 EST
Well played then :) Rebuilt upstart package is in koji.

We still end up re-executing init on shutdown, but this no longer creates this
issue. I may open another bug about that but for now its no big deal.

Note You need to log in before you can comment on or make changes to this bug.