This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 431109 - Unable to proceed to stage#2 in xen paravirt F9 Alpha
Unable to proceed to stage#2 in xen paravirt F9 Alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-01-31 15:13 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: kernel-xen-2.6-2.6.25-0.0.rc4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 11:29:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-01-31 15:13:57 EST
Description of problem:

A paravirt xen install fails to download the stage#2 image.
 * the url provided is a valid URL

Version-Release number of selected component (if applicable):

http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/i386/os
 * anaconda-11.4.0.28-1

How reproducible:
%100

Steps to Reproduce:
1. Boot images/xen/* kernel and initrd
2. Perform a URL installation source
3. Enter the URL
http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os
  
Actual results:

                   +---------------+ Error +----------------+                   
                   |                                        |                   
                   | Unable to retrieve the install image.  |                   
                   |                                        |                   
                   |                +----+                  |                   
                   |                | OK |                  |                   
                   |                +----+                  |                   
                   |                                        |                   
                   |                                        |                   
                   +----------------------------------------+                   


Expected results:

Images should be downloaded and installer proceeds to stage#2

Additional info:
 
Could this be related to the URLinstall method changes in F9
Comment 1 James Laska 2008-01-31 15:15:39 EST
I see an attempt to download the image

    +----------------------------+ Retrieving +----------------------------+    
    |                                                                      |    
    | Retrieving images/minstg2.img...                                     |    
    |                                                                      |    
    +----------------------------------------------------------------------+    


But it continues to fall back to the error dialog posted in comment#0.  There is
no other tty I can change to, and <ctrl>z is not yet active. :(

Any thoughts on grabbing more data?
Comment 2 James Laska 2008-01-31 15:27:54 EST
Chroot'd into initrd.img from an existing install...

20:05:43 INFO    : starting to STEP_URL
20:05:48 DEBUG   : url address reducto.boston.redhat.com
20:05:48 DEBUG   : url prefix /pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os
20:05:48 ERROR   : got to setupCdrom without a CD device
20:05:48 INFO    : transferring
http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os/images/updates.img
to a fd
20:05:48 INFO    : transferring
http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os/images/product.img
to a fd
20:05:48 INFO    : 533432 kB are available
20:05:48 INFO    : transferring
http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os/images/stage2.img
to a fd
20:06:09 DEBUG   : copied 44078395 bytes to /tmp/stage2.img (complete)
20:06:09 ERROR   : unable to open loop device /dev/loop0
20:06:09 ERROR   : Error mounting /dev//dev/loop0 on /mnt/runtime (No such file
or directory)
Comment 3 James Laska 2008-01-31 15:35:26 EST
please ignore comment#2 ... I suspect that's noise since the F8 system I was
chroot'ing with appears to not support the squashfs stage2.img.  

Looks like I'll need a rawhide-ish system to test this against (chicken vs egg)
Comment 4 Jeremy Katz 2008-02-04 12:49:12 EST
Can you ping the guest when it's at this point?
Comment 5 James Laska 2008-02-04 14:13:54 EST
In response to comment#4 ... it appears the guest is pingable

Feb  4 09:26:12 dhcpd-server dhcpd: DHCPDISCOVER from 00:16:3e:7f:c9:93 via eth0
Feb  4 09:26:13 dhcpd-server dhcpd: DHCPOFFER on 192.168.34.193 to
00:16:3e:7f:c9:93 via eth0
Feb  4 09:26:13 dhcpd-server dhcpd: DHCPREQUEST for 192.168.34.193
(192.168.32.2) from 00:16:3e:7f:c9:93 via eth0
Feb  4 09:26:13 dhcpd-server dhcpd: DHCPACK on 192.168.34.193 to
00:16:3e:7f:c9:93 via eth0

You have new mail in /var/spool/mail/root
# ping 192.168.34.193
PING 192.168.34.193 (192.168.34.193) 56(84) bytes of data.
64 bytes from 192.168.34.193: icmp_seq=1 ttl=64 time=7.00 ms
64 bytes from 192.168.34.193: icmp_seq=2 ttl=64 time=0.481 ms
64 bytes from 192.168.34.193: icmp_seq=3 ttl=64 time=0.516 ms

But the guest still shows:

                   +---------------+ Error +----------------+                   
                   |                                        |                   
                   | Unable to retrieve the install image.  |                   
                   |                                        |                   
                   |                +----+                  |                   
                   |                | OK |                  |                   
                   |                +----+                  |                   
                   |                                        |                   
                   |                                        |                   
                   +----------------------------------------+                   
Comment 6 Michael Young 2008-02-22 07:27:58 EST
I was seeing something similar when attempting an NFS install of Fedora 9 alpha
xen guest. It ends up with the error
                    +--------------+ Error +---------------+
                    |                                      |
                    | That directory does not seem to      |
                    | contain a Fedora installation tree.  |
                    |                                      |
                    |               +----+                 |
                    |               | OK |                 |
                    |               +----+                 |
                    |                                      |
                    |                                      |
                    +--------------------------------------+
except that it does, and the packet capture suggests it is reading bits of the
stage2.img file, then browsing the directory before putting up this error.
Comment 7 Joel Andres Granados 2008-02-25 05:35:22 EST
Regarding comment #6:  Virt-install tries to detect what type of tree it is
going to install depending on the presence of certain files in the tree.  In the
f8 version it looks for fedora.css and Fedora.  If it does not find these files
it does not see the tree at all.  I think that you are hitting this issue
because these files are not present (they are not present in
http://reducto.boston.redhat.com/pungi/f9alpha.10/9-Alpha/Fedora/x86_64/os). 
Don't know if the original issue is related to this.
Comment 8 Michael Young 2008-02-25 05:54:44 EST
Actually, I wasn't using virt-install, but booting direct from the xen vmlinuz
and initrd.img, which has worked for me for past versions of Fedora. Also an NFS
update works in a non-xen situation from the same source so the media isn't at
fault. I would guess that this might be related to having to load modules by
hand, that some modules beyond those which can be loaded by hand are missing.
Incidentally, I hope you don't mean Fedora for f8 since that directory was
renamed to Packages in f8 and f9.
Comment 9 Joel Andres Granados 2008-02-25 12:20:41 EST
(In reply to comment #8)
> Actually, I wasn't using virt-install, but booting direct from the xen vmlinuz
> and initrd.img, which has worked for me for past versions of Fedora. Also an NFS
> update works in a non-xen situation from the same source so the media isn't at
> fault. 

yep, you are correct.  you cant be hitting the issue I mentioned because the
installation does not even start.

I would guess that this might be related to having to load modules by
> hand, that some modules beyond those which can be loaded by hand are missing.
> Incidentally, I hope you don't mean Fedora for f8 since that directory was
> renamed to Packages in f8 and f9.

I know, but this has not change in python-virt.  It hasn't been an issue because
it always finds fedora.css.  its just a python-virt bug.  I think its beigh
taken care of.

Sorry for the noise.


Comment 10 James Laska 2008-03-05 13:06:55 EST
Screen captures from the system after it downloads stage2.img and fails to move fwd.

http://jlaska.fedorapeople.org/pv-xen-f9-tty1.png
http://jlaska.fedorapeople.org/pv-xen-f9-tty3.png
http://jlaska.fedorapeople.org/pv-xen-f9-tty4.png
Comment 11 Jeremy Katz 2008-03-05 13:28:49 EST
Aha, that's very helpful.

kernel-xen has outdated squashfs and thus can't mount the images.  2.6.21
strikes again.
Comment 12 Michael Young 2008-03-05 13:58:33 EST
Yes, my testing also confirms squashfs is the problem, as you can't mount the
stage2.img from Fedora 9 alpha even on an installed system running
kernel-xen-2.6.21.7-2897.fc9.i686 . The errors in /var/log/messages are
Mar  5 18:48:03 xenda kernel: loop: loaded (max 8 devices)
Mar  5 18:48:03 xenda kernel: squashfs: version 3.2-r2 (2007/01/15) Phillip Lougher
Mar  5 18:48:03 xenda kernel: SQUASHFS error: Major/Minor mismatch, trying to
mount newer 3.1 filesystem
Mar  5 18:48:03 xenda kernel: SQUASHFS error: Please update your kernel
Comment 13 Mark McLoughlin 2008-03-06 11:29:10 EST
Should be fixed with the kernel-xen-2.6-2.6.25-0.0.rc4.fc9 kernel in tomorrow's
rawhide

Note You need to log in before you can comment on or make changes to this bug.