Bug 431119 - [NetApp-S 5.2 bug] RHEL 5.1 root device multipathed host freezes during FCP path faults
[NetApp-S 5.2 bug] RHEL 5.1 root device multipathed host freezes during FCP p...
Status: CLOSED DUPLICATE of bug 355961
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.1
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
: OtherQA, ZStream
Depends On: 428338
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 15:22 EST by Martin George
Modified: 2010-01-11 21:40 EST (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 15:28:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin George 2008-01-31 15:22:25 EST
+++ This bug was initially created as a clone of Bug #428338 +++

This bug has been copied from bug #355961 and has been proposed
to be backported to 5.1 z-stream (EUS).

-- Additional comment from bmarzins@redhat.com on 2008-01-21 14:15 EST --
This fix has been backported.

-- Additional comment from errata-xmlrpc@redhat.com on 2008-01-30 10:31 EST --

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0050.html


-- Additional comment from marting@netapp.com on 2008-01-31 15:05 EST --
I installed the updated device-mapper-multipath package i.e.
device-mapper-multipath-0.4.7-12.el5_1.2 on my RHEL 5.1 root device multipathed
host and rebooted, but the host freeze is still reproducible during faults. As
suggested by Kiyoshi, I ran the attached script i.e. test.sh to trigger the
freeze (the freeze is also reproducible while running FC path faults on the SAN
fabric).

I don't see any prio callout binaries in /var/cache/multipathd/ (if that was
intended in the fix). The sysrq dumps (taken 10 minutes apart) seem to show both
multipathd & bash stalling on the exec system call (similar to the original case).



-- Additional comment from marting@netapp.com on 2008-01-31 15:07 EST --
Created an attachment (id=293642)
Host dumps

The attachment contains the following:

1) Config.txt - Config info of the RHEL 5.1 root device multipathed host.

2) test.sh - Script to simulate path faults.

3) msg-Jan31 - /var/log/messages

4) rhel5-1-dumps-Jan31.TXT - Sysrq dumps (taken 10 minutes apart) during the
freeze.

-- Additional comment from andriusb@redhat.com on 2008-01-31 15:16 EST --
Martin, please open a new bugzilla (clone this one) since this is marked closed
already.
Comment 1 Andrius Benokraitis 2008-01-31 15:28:38 EST
This is a clone of a 5.1 async errata that did not fix the partner's issue. (bug
428338). I'm going to close this as a dupe of the original 5.2 issue.

*** This bug has been marked as a duplicate of 355961 ***

Note You need to log in before you can comment on or make changes to this bug.