Bug 431173 - git repositories in Damned Lies only provides statistics & downloads for master branch
git repositories in Damned Lies only provides statistics & downloads for mast...
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
high Severity medium
: ---
: ---
Assigned To: Asgeir Frimannsson
Diego Búrigo Zacarão
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-01 02:12 EST by Asgeir Frimannsson
Modified: 2008-02-17 06:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 06:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes git checkout method (1.25 KB, patch)
2008-02-14 10:13 EST, Christos Trochalakis
no flags Details | Diff

  None (edit)
Description Asgeir Frimannsson 2008-02-01 02:12:14 EST
Description of problem:

Translators are unable to view statistics or download PO/POT files for
non-master-branch modules using GIT in damned lies.

How reproducible:

See stats for e.g.

https://translate.fedoraproject.org/module/anaconda
https://translate.fedoraproject.org/module/system-config-kickstart

Notice only master branch has stats
Comment 1 Asgeir Frimannsson 2008-02-04 21:16:05 EST
Fix commited in CVS and live:

http://cvs.fedoraproject.org/viewcvs/web/flpweb/modules.py?root=l10n&r1=1.11&r2=1.12
Comment 2 Asgeir Frimannsson 2008-02-07 23:42:44 EST
Reopening this until the fix really goes live...
Comment 3 Dimitris Glezos 2008-02-09 05:01:31 EST
From what I can see on both app servers DL is running (app1,2) the change has
gone live.
Comment 4 Christos Trochalakis 2008-02-14 10:13:20 EST
Created attachment 294915 [details]
fixes git checkout method
Comment 5 Dimitris Glezos 2008-02-14 10:21:59 EST
Christos, great fix, I've been wondering about those commandes.

Does this patch solve the above problem? Have you tested it and statistics are
being produced for branches other than master as well?
Comment 6 Christos Trochalakis 2008-02-14 10:31:33 EST
The above patch fixes the checkout method for git, these commands reset the
repository to match upstream.

It's pretty possible that this bug occurs because of the faulty checkout method
but I can say for sure.

I' ve not tested it in DL but I 've tested the commands in the console and they
seem to work as expected.
Comment 7 Dimitris Glezos 2008-02-16 04:08:33 EST
Did some testing and committed the patch. Let's see how it goes.
Comment 8 Christos Trochalakis 2008-02-16 05:33:01 EST
I commited a small fix. When the branch name is master the command
"git branch --track master origin/master" throws a fatal error.

http://cvs.fedoraproject.org/viewcvs/web/flpweb/modules.py?root=l10n&r1=1.13&r2=1.14
Comment 9 Dimitris Glezos 2008-02-16 22:43:46 EST
Everything seems to work now (stats updating, POT file creation dates are correct).

Discussed with Christos our approach for the git cloning and updating, and what
we currently do is the correct one. We might tweak it a bit more, but the
concept is right and our repos do what they should right now.

Closing bug report.
Comment 10 Asgeir Frimannsson 2008-02-16 23:33:12 EST
Great work Christos, thanks :)

From the status pages, e.g. firstboot [1] still only shows stats for master
branch though, although e.g. anaconda shows for all branches.. This might be a
different issue though, but reopening the bug again until we know more :)

[1] https://translate.fedoraproject.org/module/firstboot
Comment 11 Christos Trochalakis 2008-02-17 04:06:50 EST
Thanks Asgeir :)

About firstboot and probably others, this is because we haven't cloned the
firstboot repository the "new way" as we did with anaconda yesterday.

We just need to delete all our git repositories from our local-vcs cache so they
can be initiated/cloned correctly.
Comment 12 Dimitris Glezos 2008-02-17 06:34:48 EST
Git modules are updated now. I added the script that did the job at
http://fedoraproject.org/wiki/Infrastructure/SOP/Translations.

Closing bug report (hopefully we did get it this time!).

Note You need to log in before you can comment on or make changes to this bug.