Bug 431176 - radeonhd module ABI major version (3) doesn't match the server's version (4)
radeonhd module ABI major version (3) doesn't match the server's version (4)
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-01 04:23 EST by Jim Meyering
Modified: 2013-03-13 16:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-radeonhd-1.1.0-0.7.20080301git.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-01 07:27:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X log (6.28 KB, text/plain)
2008-02-01 04:23 EST, Jim Meyering
no flags Details
xorg.conf corresponding to the server log in comment #1 (1.19 KB, text/plain)
2008-02-04 04:53 EST, Jim Meyering
no flags Details
server log when there is no /etc/X11/xorg.conf file (90.51 KB, text/plain)
2008-02-04 04:54 EST, Jim Meyering
no flags Details

  None (edit)
Description Jim Meyering 2008-02-01 04:23:24 EST
Description of problem: radeonhd module API major version mismatch w/server:

$ grep '^.EE' Xorg.0.log
(EE) module ABI major version (3) doesn't match the server's version (4)
(EE) Failed to load module "radeonhd" (module requirement mismatch, 0)
(EE) No drivers available.

Version-Release number of selected component (if applicable):

# rpm -q xorg-x11-drv-radeonhd
# rpm -q xorg-x11-server-devel

How reproducible: always

Steps to Reproduce:
1. run startx
Actual results: see attached log

Expected results: no version mismatch

Additional info: in case it matters, my card is a
Radeon HD 2400PRO (Asus EAH2400PRO/HTP/256M)
Comment 1 Jim Meyering 2008-02-01 04:23:24 EST
Created attachment 293699 [details]
X log
Comment 2 Matěj Cepl 2008-02-01 16:54:01 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Jim Meyering 2008-02-04 04:52:10 EST
Thanks for the reply.  Perhaps you didn't notice that I attached the server log
above?  Am attaching the xorg.conf file I used.

I've also tried with no xorg.conf whatsoever, and will attach the corresponding log.
Comment 4 Jim Meyering 2008-02-04 04:53:15 EST
Created attachment 293875 [details]
xorg.conf corresponding to the server log in comment #1
Comment 5 Jim Meyering 2008-02-04 04:54:50 EST
Created attachment 293876 [details]
server log when there is no /etc/X11/xorg.conf file

By the way, when I tried this (no xorg.conf file at all), the screen remained
black, and I ended up killing the server via C-Alt-Backspace.
Comment 6 Matěj Cepl 2008-02-05 04:42:32 EST
Sorry, that request for log was a typo of course -- I overlooked that you have
already attached one and haven't deleted it from my boilerplate request text.
Sorry again.

Now, it is perfect (well, the situation is far from perfect, of course) --
passing this to developers.
Comment 7 Hans Ulrich Niedermann 2008-02-05 13:29:59 EST
I have built a new snapshot with current rawhide:

Jim, does that fix the problem?

If so, I should try to find out some way to find out that ABI version and add
the appropriate install-time requirements at package build time in some way.

(I'm still running F-8 on my test machine.)
Comment 8 Jim Meyering 2008-02-05 14:20:38 EST
Thanks, Hans.  Yes, with that, "startx" actually gets me to the desktop.
Now, I can work towards getting higher resolution (1200x1600).
Comment 9 Hans Ulrich Niedermann 2008-03-01 07:27:37 EST
Fixed in xorg-x11-drv-radeonhd-1.1.0-0.7.20080301git.fc9

Note You need to log in before you can comment on or make changes to this bug.