Bug 431239 - Unable to connect to Anaconda VNC sessions
Unable to connect to Anaconda VNC sessions
Status: CLOSED DUPLICATE of bug 440340
Product: Fedora
Classification: Fedora
Component: vinagre (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-01 13:04 EST by Adam Huffman
Modified: 2008-04-07 07:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 07:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2008-02-01 13:04:04 EST
Description of problem:
Several times I've been running anaconda for installation and using the VNC
facility.  I've tried to connect to the VNC session with vinagre but it just
showed an error message about not being able to connect.  In each case the old
vncviewer did work.

Version-Release number of selected component (if applicable):
vinagre-0.3-2.fc8

How reproducible:


Steps to Reproduce:
1. Boot to anaconda with VNC settings
2. Try connecting to VNC session
3.
  
Actual results:
Connection not made

Expected results:
Connection should be made

Additional info:
Comment 1 Bastien Nocera 2008-04-01 10:48:27 EDT
Could you please test with the updated gtk-vnc 0.3.4 and vinagre 0.4 updates
available (shortly) in the updates-testing repository?

If it's still a problem, please install gtk-vnc-python, and try running:
/usr/share/doc/gtk-vnc-python-0.3.4/gvncviewer.py host:display password

And let us know whether you see the same problem.
Comment 2 Adam Huffman 2008-04-04 06:22:27 EDT
Okay, just tried those and they either fail to connect (which is I think the
result of the ambiguity of the connection dialog and the fact that it doesn't
allow the more widely used host:display convention) or crash.

I tried the second suggestion and here's the output:

[adam@saintloup ~]$ /usr/share/doc/gtk-vnc-python-0.3.4/gvncviewer.py
192.168.122.158:1 <password>

Gdk-ERROR **: The program 'gvncviewer.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 156 error_code 12 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...

(process:23563): Gdk-ERROR (recursed) **: The program 'gvncviewer.py' received
an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 157 error_code 3 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Multiple segmentation faults occurred; can't display error dialog

I'm running compiz on the host, if that makes any difference
Comment 3 Adam Huffman 2008-04-04 06:29:58 EDT
Okay, just tried those and they either fail to connect (which is I think the
result of the ambiguity of the connection dialog and the fact that it doesn't
allow the more widely used host:display convention) or crash.

I tried the second suggestion and here's the output:

[adam@saintloup ~]$ /usr/share/doc/gtk-vnc-python-0.3.4/gvncviewer.py
192.168.122.158:1 <password>

Gdk-ERROR **: The program 'gvncviewer.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 156 error_code 12 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...

(process:23563): Gdk-ERROR (recursed) **: The program 'gvncviewer.py' received
an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 157 error_code 3 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Multiple segmentation faults occurred; can't display error dialog

I'm running compiz on the host, if that makes any difference
Comment 4 Bastien Nocera 2008-04-04 06:49:56 EDT
This is a bug in GTK+ (bug 440340). Please run "xprop  -root -remove
RGB_DEFAULT_MAP" before re-running the test program.
Comment 5 Daniel Berrange 2008-04-04 07:56:44 EDT
If you upgrade to this GTK build it will fix the BadCOlor problems:

http://koji.fedoraproject.org/packages/gtk2/2.12.9/2.fc9/
Comment 6 Bastien Nocera 2008-04-04 08:37:32 EDT
Adam is on F8, not rawhide, otherwise I'd have asked for the GTK+ update :)
Comment 7 Adam Huffman 2008-04-04 09:10:39 EDT
Yes, on this machine I'm running F8 - upgrading to that gtk version wasn't
entirely successful and I've downgraded now.

So the test program does connect to the anaconda VNC session after I've run that
xprop command.
Comment 8 Bastien Nocera 2008-04-04 09:27:29 EDT
So the test program works, but vinagre doesn't?
Comment 9 Daniel Berrange 2008-04-04 09:51:33 EDT
I've tested Vinagre from rawhide against Anaconda from rawhide & it connects
fine. When using vinagre are you specifying the host/port from the command line
or via the UI?  If using the command line becareful that you're using the
correct format. Unusually vinagre expects  host:port, not host:display, 

eg  localhost:5901  instead of localhost:1
Comment 10 Adam Huffman 2008-04-04 16:39:18 EDT
I just forgot to test vinagre as well as the other program.  Will have access to
that system again on Monday, so I'll test this then (have tried running things
remotely but for some reason when I start the virtual machine it crashes X...)
Comment 11 Adam Huffman 2008-04-07 06:55:07 EDT
Yes, vinagre works on my F8 host when I run that xprop command.
Comment 12 Bastien Nocera 2008-04-07 07:17:37 EDT
I'm building a GTK2 update for F-8 now.

*** This bug has been marked as a duplicate of 440340 ***

Note You need to log in before you can comment on or make changes to this bug.