Bug 431245 - traceback in resolving deps (as part of spam-o-matic / repocloser )
Summary: traceback in resolving deps (as part of spam-o-matic / repocloser )
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 431269 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-01 18:36 UTC by Jesse Keating
Modified: 2014-01-21 23:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-12 16:47:53 UTC


Attachments (Terms of Use)

Description Jesse Keating 2008-02-01 18:36:31 UTC
Getting this traceback from rawhide creation.  Just once so far, haven't tested
it again yet.

CREATED comps-f9.xml
Traceback (most recent call last):
  File "/usr/share/mash/spam-o-matic", line 259, in <module>
    doit(args[0], mail)
  File "/usr/share/mash/spam-o-matic", line 208, in doit
    baddeps = my.getBrokenDeps(newest = False)
  File "/usr/bin/repoclosure", line 127, in getBrokenDeps
    resolve_sack = self.whatProvides(req, flags, ver)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 149, in whatProvides
    pkgs = self.pkgSack.searchProvides(name)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 267, in
searchProvides
    return self._computeAggregateListResult("searchProvides", name)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 401, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 720, in
searchProvides
    return self.searchPrco(name, "provides")
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 40, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 668, in searchPrco
    results.extend(self.searchFiles(name))
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 40, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 410, in
searchFiles
    pkgs.append(self._packageByKey(rep, ob['pkgKey']))
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 332, in
_packageByKey
    po = self.pc(repo, cur.fetchone())
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 61, in __init__
    self._read_db_obj(db_obj)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 84, in
_read_db_obj
    setattr(self, item, db_obj[item])
TypeError: 'NoneType' object is unsubscriptable

Comment 1 James Antill 2008-02-01 22:06:23 UTC
*** Bug 431269 has been marked as a duplicate of this bug. ***

Comment 2 James Antill 2008-02-01 22:07:59 UTC
 Can we get a copy of the filelists and primary metadata from the repo that's
causing the problem (I assume it's "development")?


Comment 3 Christopher Aillon 2008-02-04 22:17:03 UTC
This is development, when depsolving anything to do with the libstdc++ update. 
I'm able to individually yum update other items but when an update pulls in
libstdc++, it dies.

Comment 4 Seth Vidal 2008-03-12 16:47:53 UTC
Pretty sure we've fixed this one in yum 3.2.12.


Note You need to log in before you can comment on or make changes to this bug.