Bug 431282 - After upgrade, Firefox will not find plugins anymore
Summary: After upgrade, Firefox will not find plugins anymore
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox   
(Show other bugs)
Version: 5.2
Hardware: All
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-02 00:06 UTC by Daniel Riek
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version: 5.2Beta
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 11:44:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Riek 2008-02-02 00:06:58 UTC
After upgrading to the nightly build's firefox3 (and later to the rawhide
firefox-3.0-0.beta2.15.nightly20080130.fc9), plugins don't work anymore.

E.g. the flash-plugin installed as an rpm from Supplementary seems not to be
sees by Firefox. "about:plugins" states that no plugins are installed.

Comment 1 Matěj Cepl 2008-02-02 01:38:10 UTC
Run mozilla-plugin-config -f -c and then mozilla-plugin-config -l. Does it help?
And of course, I don't dispute, that it should work out of the box, just to be
sure, what is the problem.

Comment 2 Michal Babej 2008-02-04 11:07:03 UTC
i updated from 5.1 to 5.2 nightly 20080131 and flash works for me: 

firefox-3.0-0.beta2.9.el5
xulrunner-1.9-0.beta2.9.el5
flash-plugin-9.0.115.0-1.el5

it's an i386 installation.


Comment 3 Matěj Cepl 2008-02-04 13:32:28 UTC
Reporter, did upgrade help?

Comment 4 Martin Stransky 2008-02-06 07:50:14 UTC
The latest thel-5 packages are:

firefox-3.0-0.beta2.11.el5
xulrunner-1.9-0.beta2.10.el5

so check them please. 

Comment 5 Martin Stransky 2008-02-06 15:41:47 UTC
Reporter, please attach outputs of:

ll /usr/lib(64)/mozilla -d

ll /usr/lib(64)/mozilla/plugins -d
ll /usr/lib(64)/mozilla/plugins

ll /usr/lib(64)/mozilla/plugins-wrapped -d
ll /usr/lib(64)/mozilla/plugins-wrapped

if you use nspluginwrapper, attach output of:

mozilla-plugin-config -l


Comment 7 Daniel Riek 2008-02-08 11:44:43 UTC
Works in the 20080207 nightly build


Note You need to log in before you can comment on or make changes to this bug.