Bug 431307 - ata5.00: failed to set xfermode (err_mask=0x4) - SATA DVD Writer
ata5.00: failed to set xfermode (err_mask=0x4) - SATA DVD Writer
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FCMETA_SATA
  Show dependency treegraph
 
Reported: 2008-02-02 08:06 EST by andrew.berridge
Modified: 2013-07-02 22:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.24.3-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 16:39:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew.berridge 2008-02-02 08:06:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
When booting, get error:

ata5.00: failed to set xfermode (err_mask=0x4)

I have a SATA DVD-Writer - Pioneer DVR-212. During boot, I get several instances of the above message with delays between each. The PC will boot, but the DVD writer is not visible.

I have seen similar reported before, but not against FC8... I have also tried adding irqpoll to the kernel boot options, but this has no effect.

I have tried Ubuntu 7.10 on the same hardware, and it works perfectly. I believe it's running 2.6.20(something)

Version-Release number of selected component (if applicable):
F8 Kernels, incl. 2.6.23.14-107.fc8

How reproducible:
Always


Steps to Reproduce:
1.Boot with DVR-212 on any SATA interface


Actual Results:
Error message as described, DVD Writer not visible

Expected Results:
No error message, DVD writer visible

Additional info:
The dmesg output is as follows:

ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata5.00: ATAPI: PIONEER DVD-RW  DVR-212, 1.24, max UDMA/66
ata5.00: qc timeout (cmd 0xef)
ata5.00: failed to set xfermode (err_mask=0x4)
ata5: failed to recover some devices, retrying in 5 secs
ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata5.00: qc timeout (cmd 0xef)
ata5.00: failed to set xfermode (err_mask=0x4)
ata5: limiting SATA link speed to 1.5 Gbps
ata5.00: limiting speed to UDMA/66:PIO3
ata5: failed to recover some devices, retrying in 5 secs
ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata5.00: qc timeout (cmd 0xef)
ata5.00: failed to set xfermode (err_mask=0x4)
ata5.00: disabled
ata5: EH pending after completion, repeating EH (cnt=4)
ata5: soft resetting port
ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata5: EH complete
ata6: SATA link down (SStatus 0 SControl 300)


Motherboard is Gigabyte GA-73PVM-S2H

lspci:
00:00.1 RAM memory: nVidia Corporation Unknown device 07cb (rev a2)
00:01.0 RAM memory: nVidia Corporation Unknown device 07cd (rev a1)
00:01.1 RAM memory: nVidia Corporation Unknown device 07ce (rev a1)
00:01.2 RAM memory: nVidia Corporation Unknown device 07cf (rev a1)
00:01.3 RAM memory: nVidia Corporation Unknown device 07d0 (rev a1)
00:01.4 RAM memory: nVidia Corporation Unknown device 07d1 (rev a1)
00:01.5 RAM memory: nVidia Corporation Unknown device 07d2 (rev a1)
00:01.6 RAM memory: nVidia Corporation Unknown device 07d3 (rev a1)
00:02.0 RAM memory: nVidia Corporation Unknown device 07d6 (rev a1)
00:03.0 ISA bridge: nVidia Corporation Unknown device 07d7 (rev a2)
00:03.1 SMBus: nVidia Corporation Unknown device 07d8 (rev a1)
00:03.2 RAM memory: nVidia Corporation Unknown device 07d9 (rev a1)
00:03.4 RAM memory: nVidia Corporation Unknown device 07c8 (rev a1)
00:04.0 USB Controller: nVidia Corporation Unknown device 07fe (rev a1)
00:04.1 USB Controller: nVidia Corporation Unknown device 056a (rev a1)
00:08.0 IDE interface: nVidia Corporation Unknown device 056c (rev a1)
00:09.0 Audio device: nVidia Corporation Unknown device 07fc (rev a1)
00:0a.0 PCI bridge: nVidia Corporation Unknown device 056d (rev a1)
00:0b.0 PCI bridge: nVidia Corporation Unknown device 056e (rev a1)
00:0c.0 PCI bridge: nVidia Corporation Unknown device 056f (rev a1)
00:0d.0 PCI bridge: nVidia Corporation Unknown device 056f (rev a1)
00:0e.0 IDE interface: nVidia Corporation Unknown device 07f0 (rev a2)
00:0f.0 Ethernet controller: nVidia Corporation Unknown device 07dc (rev a2)
00:10.0 VGA compatible controller: nVidia Corporation Unknown device 07e1 (rev a2)
01:05.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:05.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
1:05.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
01:06.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
Comment 1 Andrew Hall 2008-02-29 09:25:07 EST
This thread...

http://bugzilla.kernel.org/show_bug.cgi?id=8650

.../might/ suggest that 2.6.24-rc2 fixes the issue.

I have yet to test this.
Comment 2 Chuck Ebbert 2008-02-29 16:21:14 EST
2.6.24.3-12 is in the updates-testing repository.
Comment 3 andrew.berridge 2008-02-29 18:00:44 EST
Thanks for the info. Sadly, will be unable to test for 1 week! Will test next
Friday...
Comment 4 Andrew Hall 2008-03-05 17:35:43 EST
I can confirm that this kernel has not fixed the issue. This is an AHCI/SATA
issue that FC8 is not dealing with, is affecting a lot of users, but seemingly
not being looked at. If this is not a bug, can someone please tell me what it is
and how to fix it?
Comment 5 Chuck Ebbert 2008-03-05 17:48:13 EST
Does adding "adma=0" the the module options help?

1. edit /etc/modprobe.conf and add/change this line:

   options sata_nv adma=0

2. Rebuild the initrd (or reinstall the kernel.)
Comment 6 andrew.berridge 2008-03-07 16:39:40 EST
Hi Andrew/Chuck,

Well. happily for me, 2.6.24.3-12 fixes it for me! I can get rid of Ubuntu and
go back to my lovely Fedora...

I didn't have to do any of the adding adma=0 or sata_nv options...

Andrew Hall - have you still got the problem? Have you tried Chuck's suggestion?

I have changed this bug's status to worksforme.

Andrew
Comment 7 Andrew Hall 2008-03-19 10:30:49 EDT
(In reply to comment #5)
> Does adding "adma=0" the the module options help?
> 
> 1. edit /etc/modprobe.conf and add/change this line:
> 
>    options sata_nv adma=0
> 
> 2. Rebuild the initrd (or reinstall the kernel.)
> 

Sadly this makes no difference, but it doesn't seem I have the sata_nv module
running anyway, as lsmod doesn't show it.

Any final suggestions before I purchase an external drive?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.