Bug 431311 - Shutdown of Fedora hangs at stopping autofs....
Shutdown of Fedora hangs at stopping autofs....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 10:27 EST by Rolf Linder
Modified: 2008-07-11 09:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 09:45:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog of shutdown... (4.97 KB, text/plain)
2008-02-02 10:33 EST, Rolf Linder
no flags Details
Yum-Log (16.35 KB, text/plain)
2008-02-03 13:16 EST, Rolf Linder
no flags Details
logfile of clean packages (no impact to shutdown problem) (5.77 KB, text/plain)
2008-02-05 15:53 EST, Rolf Linder
no flags Details

  None (edit)
Description Rolf Linder 2008-02-02 10:27:10 EST
Description of problem:
When you setup an autofs configuration (mounts of remote nfs-shares) you're
unable to clean shutdown / reboot your fedora 8 anymore! this problem was
intruduced in the last 2-3 weeks...at the beginning of using fedora8 this
problem did not exist.

Version-Release number of selected component (if applicable):
Fedora8, autofs-5.0.2-24

How reproducible:
setup an automount entry as probably the following:

---
localmount           -fstype=nfs,soft        [nfs-server]:/path/to/nfsexporteddir
---
add your file in auto.master:
---
/rootdir   /etc/[yourfile] --ghost
---

reload autofs (ensure that selinux context of newly created file is right -> ll
-Z /etc/auto.*) and access the directory....verify with "mount" that remote
directory was mounted....shutdown or reboot your machine...

Steps to Reproduce:
( listed above )
  
Actual results:
Reboot / Shutdown hangs at stopping autofs: .....and again at unmounting nfs ....
this state can take up to 10/20 minutes without going on!!

Expected results:
stopping of autofs (unmounting mounts) reboot / shutdown...

Additional info:
Comment 1 Rolf Linder 2008-02-02 10:33:10 EST
Created attachment 293796 [details]
syslog of shutdown...

I've setup in /etc/sysconfig/autofs LOGGING to debug....here you'll find a
systemlog of my shutdown process...

please note: shutdown was started on 10:17:28...at 10:17:30 (2 seconds later)
we're hanging at stopping autofs for over 45 seconds. that time it was quite
short ....I've seen states where stopping autofs and shutting down takes over
10mins....
Comment 2 Rolf Linder 2008-02-02 10:35:22 EST
just for information....if you reconfigure (stop autofs) and use manually setup
nfs-mounts (by hand) theres no problem shutting down / rebooting....
In short: if no autofs (automount) is involved no problems....
Comment 3 Ian Kent 2008-02-03 06:33:18 EST
I'll investigate.

In the mean time I've removed a patch isn't going
upstream, at least for now. I don't think it will
make a difference but give autofs-5.0.2-26 a try
when it gets to the mirrors.

Ian
Comment 4 Rolf Linder 2008-02-03 13:08:03 EST
Ok, after 2h of testing I've some news about this bug....

I setup a fresh installation of Fedora8 (as expected, problem does not
exist)...I made the upgrades of kernel-package, autofs and nfs-utils-lib step by
step (and tested after every update). I did also about the
dbus-upgrades....after this, problem still does not exist (with actual kernel,
autofs and nfs-utils-package) -> quite strange....

I then did all the rest of the updates (over 160 packages) and then...we have
the problem again...so it seems that its not directly related to an
autofs-update (or nfs-libs)...

unfortunately I could not detect which package did force the problem again...but
I've the list of updates which are possible (see attachment)...

cheers, Rolf
Comment 5 Rolf Linder 2008-02-03 13:16:05 EST
Created attachment 293838 [details]
Yum-Log

Here, you'll find the yum-log...I made an entry when until when the problem was
not seen....the whole updates of (as I thought) unrelated autofs/nfs tools was
done in one step...
Comment 6 Ian Kent 2008-02-04 00:36:32 EST
Ha, that makes it a bit hard, none of the usual suspects
are included in the following package list.

Ian
Comment 7 Rolf Linder 2008-02-04 03:37:16 EST
Yes I know....I had same thoughts :)

I'll to another tests as soon as I've time for it and will go on further reduce
the list of possible packages (right now the list is to big)...but unfortunately
this is quite time-consuming (as of the reboots and so on)...

I'll post my results...

Rolf
Comment 8 Rolf Linder 2008-02-05 15:53:12 EST
Created attachment 294043 [details]
logfile of clean packages (no impact to shutdown problem)

these updates can be installed without any impact to the above described
problem....there are still over 130 packages left to test....I'm working on
it...
Comment 9 Rolf Linder 2008-02-06 16:22:02 EST
Ok, here some news about this:

I've tested the rest of the updates and finally solved the anomaly of this. its
not related to any update...its related to the NetworkManager.

If you're using NetworkManager in combination of autofs this problem occurs: you
cannot properly shutdown...if you deactivate (or stop) the NetworkManager you
can normaly shutdown.
So, this issue is an NetworkManager problem...
Comment 10 Jeff Moyer 2008-02-06 16:33:45 EST
Darnit!  I've actually run into this and debugged it in the past.  We really
need to fix this.  In my case, I think the problem was that the NetworkManager
stop script shut down the ethernet interface, even though it wasn't the one to
set it up (it was setup by dhclient).  I believe I simply moved the
NetworkManager stop script later in the shutdown process than autofs.
Comment 11 Rolf Linder 2008-02-07 02:41:03 EST
Yes, thats a logical solution. I would suggest to correct the init-script of
NetworkManager....
in my opinon (or as long as NetworkManager does shutdown the interfaces at the
stopping) it should have the same Stop-Priority as networking init-script...not
another.

Cheers, Rolf
Comment 12 Rolf Linder 2008-02-08 11:53:24 EST
Ok, just changing the stop priority of NetworkManager does not work as a
workaround...You need to deactivate NetworkManager in order to cleanly shutdown
/ reboot your Fedora8....
Comment 13 François Kooman 2008-05-04 08:08:13 EDT
This is still an issue in rawhide as of this moment. Rawhide uses NetworkManager
by default, so using the automatic NFS mounts using /net/<servername>/share
works great, but shutdown stops working after doing this...

Comment 14 Rolf Linder 2008-05-04 10:39:15 EDT
Me too can confirm this. Working with an updated rawhide still does have this
problem.....so in short: also in F9 preview working with NetworkManager AND
autofs ist not possible...

really too bad...

Note You need to log in before you can comment on or make changes to this bug.