Bug 431321 - Incorrect mails with check only when a repo is not accessible
Incorrect mails with check only when a repo is not accessible
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-cron (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Habig, Alec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 15:14 EST by Ville Skyttä
Modified: 2008-02-28 16:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:36:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-02-02 15:14:24 EST
yum.cron.daily treats all non-zero yum exit codes as equal in CHECK_ONLY
configurations.  Today I got several mails from it like the below because the
EPEL mirror I use was not available (yeah, this is on EL but I think Fedora is
the upstream for yum-cron there so it'd be better to fix it in Fedora I think):

----
/etc/cron.daily/yum.cron:

New updates available for host xxx:


Error: Cannot open/read repomd.xml file for repository: epel
Updates downloaded, use "yum -C update" manually to install them.
----

yum check-update is documented to return 0 if no updates are available, and 100
if there are updates available.  yum.cron.daily should not treat all non-zero
exit codes as "updates are available" ones.  I have mixed feelings about whether
it should even mail me if a repo was not available, but certainly not like it
currently does :)
Comment 1 Habig, Alec 2008-02-20 10:45:00 EST
Similar to the CHECK_FIRST solution presented in bug 429716.  For CHECK_ONLY
setups, looks like this should always be done.  Working on both bugs now.
Comment 2 Fedora Update System 2008-02-21 10:47:56 EST
yum-cron-0.8-1.fc7 has been submitted as an update for Fedora 7
Comment 3 Fedora Update System 2008-02-21 10:48:48 EST
yum-cron-0.8-1.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-02-25 19:21:49 EST
yum-cron-0.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1916
Comment 5 Fedora Update System 2008-02-28 16:36:36 EST
yum-cron-0.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-02-28 16:42:23 EST
yum-cron-0.8-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.