Bug 431325 - compiz-kde includes obsolete (KDE 3) kde-window-decorator (broken dep)
Summary: compiz-kde includes obsolete (KDE 3) kde-window-decorator (broken dep)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-02 20:29 UTC by Kevin Kofler
Modified: 2008-03-25 18:00 UTC (History)
3 users (show)

Fixed In Version: 0.7.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 18:00:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Kofler 2008-02-02 20:29:03 UTC
Description of problem:
The compiz-kde package currently has broken dependencies because it includes a 
kde-window-decorator using KWin 3 libraries, which are no longer available in 
Fedora 9 and later. Please disable the kde-window-decorator until a KDE 4 
version is available.

Version-Release number of selected component (if applicable):
compiz-kde-0.6.2-6.fc9

Additional info:
The broken dependency:
compiz-kde-0.6.2-6.fc9.i386 requires libkdecorations.so.1

Comment 1 Rex Dieter 2008-03-21 14:42:27 UTC
Ping, this has been broken since introduction of kde4 into rawhide.

What's the status here?  Any plans for kde4 support?  

If kde4 support isn't coming soon, compiz-kde should probably be EOL'd and
Obsoleted.

Comment 2 Alex Lancaster 2008-03-24 13:05:56 UTC
Just confirming that this has been in the broken deps list for > 6 weeks:

Broken deps for i386
----------------------------------------------------------
        compiz-kde-0.6.2-6.fc9.i386 requires libkdecorations.so.1
   

Comment 3 Alex Lancaster 2008-03-24 13:07:27 UTC
I agree(In reply to comment #1)
 
> If kde4 support isn't coming soon, compiz-kde should probably be EOL'd and
> Obsoleted.

I concur with Rex here, please EOL it if KDE4 won't work with soon.


Comment 4 Kevin Kofler 2008-03-25 18:00:27 UTC
Compiz was just upgraded to 0.7.2 in Rawhide which now supports a KDE 4 window 
decorator, which is now enabled in the Rawhide packages.


Note You need to log in before you can comment on or make changes to this bug.