This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 431349 - sound stops working after a bit
sound stops working after a bit
Status: CLOSED DUPLICATE of bug 384271
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 02:07 EST by David Baron
Modified: 2008-02-28 13:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 13:16:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Baron 2008-02-03 02:07:38 EST
Description of problem:  After running for a few days, sound pretty reliably
stops working.  I'm not sure if it's the number of suspends+resumes or something
else.  (Although I'm pretty sure it has worked after a single suspend+resume.)

Version-Release number of selected component (if applicable):
pulseaudio-0.9.8-5.fc8
kernel-2.6.23.14-107.fc8

How reproducible:  Pretty much always, although it takes a few days.

Steps to Reproduce:
1. aplay /usr/share/sounds/warning.wav (after running for a few days)
  
Actual results:
aplay hangs after printing:

share/sounds/warning.wav 
Playing WAVE '/usr/share/sounds/warning.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Mono

When I hit Ctrl-C, it prints:

Aborted by signal Interrupt...
aplay: pulsecore/mutex-posix.c:85: pa_mutex_free: Assertion
`pthread_mutex_destroy(&m->mutex) == 0' failed.
Aborted by signal Aborted...

The following pair of lines is added to ~/.xsession-errors :

ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM front:0

Expected results: sound plays

Additional info:  Sound seems to fail in all applications except for the
terminal bell in gnome-terminal.
Comment 1 David Baron 2008-02-03 02:08:52 EST
And the following gets added to /var/log/messages:

Feb  3 06:57:57 ridley pulseaudio[2743]: module-alsa-sink.c: Error opening PCM
device front:0: Invalid argument
Comment 2 Lubomir Kundrak 2008-02-28 13:16:33 EST
If you do suspend - resume you are subject to a hal problem.

*** This bug has been marked as a duplicate of 384271 ***

Note You need to log in before you can comment on or make changes to this bug.