Bug 43135 - ip6tables et al. look for /usr/lib/iptables/*.so
Summary: ip6tables et al. look for /usr/lib/iptables/*.so
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-01 07:18 UTC by Pekka Savola
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 20:28:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-06-01 07:18:33 UTC
ip6tables and friends look for /usr/lib/iptables/*.so etc., instead of
/lib/iptables.

This can be noticed with 'strace ip6tables -L'.

This is caused by the fact that some part of the code was changed to
IP6T_LIB_DIR, but
makefile was forgotten to be changed.  There is a fix in netfilter CVS for
this.

Also, ip6tables-{save,restore} could be added, even if they aren't of too
much use yet.

There is .src.rpm with these (against 1.2.2-1) at
http://www.netcore.fi/pekkas/linux/ipv6/

Comment 1 Pekka Savola 2001-06-26 20:28:02 UTC
Reminder.  The fix is from CVS, and should be quite non-controversial.

Comment 2 Bernhard Rosenkraenzer 2001-07-10 15:17:40 UTC
Fixed in 1.2.2-3



Note You need to log in before you can comment on or make changes to this bug.