Bug 431352 - [PATCH] Get rid of diffutils (/usr/bin/cmp) dependency
[PATCH] Get rid of diffutils (/usr/bin/cmp) dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 06:02 EST by Ville Skyttä
Modified: 2008-03-26 08:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 08:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
CMP helper that works without diffutils (215 bytes, text/plain)
2008-02-03 06:02 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2008-02-03 06:02:51 EST
Looks like it would be easy to get rid of the diffutils dependency in man,
installing something like the attached script to let's say
/usr/libexec/man-cmp.sh and setting CMP to it in /etc/man.config should do the
trick.

More discussion at
http://www.redhat.com/archives/fedora-devel-list/2008-January/msg02881.html
Comment 1 Ville Skyttä 2008-02-03 06:02:51 EST
Created attachment 293831 [details]
CMP helper that works without diffutils
Comment 2 Ivana Varekova 2008-03-26 08:38:08 EDT
Thanks. Fixed in man-1.6f-2.fc9.

Note You need to log in before you can comment on or make changes to this bug.