Bug 431361 - Install hangs when loading 8139too module on some laptops (twinhead H12Y)
Summary: Install hangs when loading 8139too module on some laptops (twinhead H12Y)
Status: CLOSED DUPLICATE of bug 430274
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-03 16:00 UTC by Fredrik Jansson
Modified: 2008-02-03 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 16:38:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fredrik Jansson 2008-02-03 16:00:51 UTC
Description of problem:
On a Philips freevents X-55 laptop, (similar to twinhead H12Y)
the install hangs when loading the module 8139too. 
This applies to both x86_64 and i386 versions of fedora.

The 8139too module can be used on this machine, if it is recompiled with
"USE PIO instead of MMIO (8139TOO_PIO)" and 
8139TOO_OLD_RX_RESET

This problem has been reported before on other distributions:
http://ubuntuforums.org/showthread.php?t=377743
http://www.linuxquestions.org/questions/linux-laptop-and-handheld-25/philips-freevents-x52-hardware-dection-hang-475612/
 
As a workaround I installed by booting with diskboot.img from a USB memory
stick, after removing the modules 8139* from modules/modules.cgz
inside initrd.img
When the install is complete, but before the first reboot,
I removed 8139*.ko from /lib/modules...
Also the memory card reader module sdhci.ko causes the system to hang.
It can be removed at the same time.


--Fredrik
 

Additional info:
relevant parts of lspci -vv (for memory card reader and ethernet)

03:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: TWINHEAD INTERNATIONAL Corp Unknown device a003
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64 (8000ns min, 16000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at c800 [size=256]
        Region 1: Memory at ffbffc00 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel modules: 8139cp, 8139too


03:06.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 01)
        Subsystem: TWINHEAD INTERNATIONAL Corp Unknown device a003
        Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at ffbff800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel modules: sdhci

03:06.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
        Subsystem: TWINHEAD INTERNATIONAL Corp Unknown device a003
        Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at ffbfd000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>

Comment 1 Jon Stanley 2008-02-03 16:38:40 UTC

*** This bug has been marked as a duplicate of 430274 ***


Note You need to log in before you can comment on or make changes to this bug.