Bug 431364 - Package is being built using prebuilt jars
Package is being built using prebuilt jars
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: diveintopython (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marc Wiriadisastra
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 11:44 EST by Mohd Izhar Firdaus Ismail
Modified: 2008-02-25 19:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 09:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated spec file. (5.72 KB, text/x-rpm-spec)
2008-02-05 08:57 EST, Marc Wiriadisastra
no flags Details

  None (edit)
Description Mohd Izhar Firdaus Ismail 2008-02-03 11:44:43 EST
Description of problem:

diveintopython make.sh builds the documents using prebuilt jars, it should build
them using Fedora packages instead.
Comment 1 Andrew Overholt 2008-02-03 14:01:53 EST
There are 6 pre-built jars:

ant.jar

This is part of the ant package.

crimson.jar

It doesn't look like there's a package for this in Fedora.  Perhaps something at
JPackage could be brought over?

jaxp.jar

xml-commons-apis-1.3.04 provides this jar.

NetComponents.jar

According to [1], "NetComponents users should upgrade to Apache Commons Net." 
See the jakarta-commons-net package.

optional.jar

If none of the ant packages provide this, talk to the ant package maintainers.

saxon.jar

There's a saxon package in Fedora.

These dependencies should be added (and in some cases added to Fedora entirely)
to diveintopython.  The package should not have been included in Fedora until
its dependencies were in order.  We can't change that now, of course, so let's
clean these up :)

[1]
http://www.savarese.org/oro/index.html
Comment 2 Marc Wiriadisastra 2008-02-03 17:00:09 EST
This post is just for a reference in case my links crash while I'm at work.

crimson.jar

http://xml.apache.org/crimson/
http://www.jpackage.org/browser/rpm.php?jppversion=1.7&id=6668
This package is not in Fedora but in jpackage so I'll create a review for it. Do
I have to modify it since some packages in Fedora are just straight 'copies'
from jpackage?

http://ant.apache.org/faq.html

I'll work on patching it or running the command directly later today.

Comment 3 Marc Wiriadisastra 2008-02-03 17:13:04 EST
crimson requires gnu-crypto
http://www.jpackage.org/browser/rpm.php?jppversion=1.7&id=5839
Comment 4 Marc Wiriadisastra 2008-02-04 07:35:21 EST
Currently gnu-crypto doesn't build. There is an @redhat email there so I have
emailed the packager and asked whether they are able to submit it to Fedora.
Comment 5 Matt Wringe 2008-02-04 17:26:35 EST
you shouldn't need to use crimson, use xerces instead (they are both xml parsers).

gnu-crypto became part of classpath a couple of years ago, the classpath
libraries are in the libgcj package. This dependency shouldn't be needed, as the
crypto provides are in the modern jvms. The only reason you should need the
gnu-crypto package is if its trying to use org.gnu.crypto.* classes (which I
highly doubt).

I would suggest removing the dependency on crimson and use xerces instead, and
remove the dependency on gnu-crypto all together. This will require updating the
spec file and possibly patching a couple of files.
Comment 6 Marc Wiriadisastra 2008-02-05 08:57:04 EST
Created attachment 293996 [details]
Updated spec file.

Would this fix the situation just double checking before uploading another
version of an incorrect spec file :)
Comment 7 Marc Wiriadisastra 2008-02-05 09:00:43 EST
SRPM for your perusal.

If this fixes it I'll upload it to fix this bug.
http://mwiriadi.fedorapeople.org/packages/diveintopython/diveintopython-5.4-12.fc8.src.rpm
Comment 8 Andrew Overholt 2008-02-05 09:18:19 EST
I worked with Marc a bit on IRC and I'm satisfied that it's no longer using the
pre-built jars.  He's going to add saxon as a BR and fix his super-long
changelog lines and update CVS.  Thanks, Marc!
Comment 9 Fedora Update System 2008-02-07 08:36:07 EST
diveintopython-5.4-12.fc8 has been submitted as an update for Fedora 8
Comment 10 Marc Wiriadisastra 2008-02-07 08:41:15 EST
It doesn't build on F-7 which is annoying. 
http://koji.fedoraproject.org/koji/getfile?taskID=398537&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=398537&name=root.log
http://koji.fedoraproject.org/koji/getfile?taskID=398537&name=state.log

DEBUG util.py:261:  No Package Found for ant-commons-net

Any suggestions on how to fix this or what I should do?
Comment 11 Andrew Overholt 2008-02-07 08:48:35 EST
(In reply to comment #10)
> DEBUG util.py:261:  No Package Found for ant-commons-net
> 
> Any suggestions on how to fix this or what I should do?

Build ant-commons-net for F-7 or bug the owner of that package to do so.
Comment 12 Fedora Update System 2008-02-25 19:28:36 EST
diveintopython-5.4-12.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.