Bug 431385 - Server discovery stopped working in Management console.
Server discovery stopped working in Management console.
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.1.0
i386 All
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 19:36 EST by Alan Madill
Modified: 2015-01-04 18:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 19:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (33.46 KB, image/jpeg)
2008-02-03 19:36 EST, Alan Madill
no flags Details
Console logs from -D 9 -f console.log (5.44 KB, application/x-zip-compressed)
2008-02-05 11:57 EST, Alan Madill
no flags Details

  None (edit)
Description Alan Madill 2008-02-03 19:36:59 EST
Description of problem:
Server discovery stopped working in Management console.
Console opens in both Windows and Linux versions.  The list of servers and 
applications is blank.  Can still add and manipulate users and groups

Version-Release number of selected component (if applicable):


How reproducible:
Happens only with one directory server.  Others behave normally.

Steps to Reproduce:
1. Open console.
2.
3.
  
Actual results:
No list of servers

Expected results:


Additional info:
Checked logs - no errors
Comment 1 Alan Madill 2008-02-03 19:36:59 EST
Created attachment 293847 [details]
Screenshot
Comment 2 Alan Madill 2008-02-03 20:14:11 EST
I find that I can log in as cn=Directory Manager see thread...
http://www.redhat.com/archives/fedora-directory-users/2007-
February/msg00005.html
Comment 3 Rich Megginson 2008-02-04 10:11:30 EST
So it works if you login as cn=Directory Manager, but not as admin?

Can you run the console in the failure mode with -D 9 -f console.log then attach
the file console.log to this bug?  Thanks.
Comment 4 Alan Madill 2008-02-05 11:57:42 EST
Created attachment 294019 [details]
Console logs from -D 9 -f console.log
Comment 5 Alan Madill 2008-02-05 12:06:56 EST
Looking back on the sequence of events I created a new administrative user, 
logged in as that entity, logged off and back on again as admin, and I think it 
was at that point that the server list disappeared.  Attached are two console 
logs, one as admin and the other as Directory manager.
I see in a ldif export that the console user settings are stored in the 
directory itself with a new one created with each login.  Would those help?
Comment 6 Rich Megginson 2008-02-27 23:14:00 EST
What happens if you restart the Admin Server?
Comment 7 Rich Megginson 2008-07-08 17:19:05 EDT
(In reply to comment #5)
> Looking back on the sequence of events I created a new administrative user, 
> logged in as that entity, logged off and back on again as admin, and I think it 
> was at that point that the server list disappeared.  Attached are two console 
> logs, one as admin and the other as Directory manager.
> I see in a ldif export that the console user settings are stored in the 
> directory itself with a new one created with each login.  Would those help?

What do you mean by "created a new administrative user"?
Comment 8 Alan Madill 2008-07-08 20:27:24 EDT
Under ou=administrators,ou=topologymanagement,o=netscaperoot I created a new 
user and then logged in as that identity.
Comment 9 Rich Megginson 2008-07-08 22:17:20 EDT
(In reply to comment #8)
> Under ou=administrators,ou=topologymanagement,o=netscaperoot I created a new 
> user and then logged in as that identity.

I think there is more that needs to happen.  There are several ACIs that need to
be set to allow that new user to have certain types of access.  There are
certain groups that user needs to be added to.  One quick&dirty way to see would
be to search for everything under o=NetscapeRoot and grep for uid=admin.
Comment 10 Rich Megginson 2008-12-19 19:30:48 EST
I'm going to close this bug as not a bug.  I think the real solution to this particular problem would be to have a GUI or a least a written procedure that allows you to create another admin user.

Note You need to log in before you can comment on or make changes to this bug.