Bug 431392 - cp: cannot stat `chroot': No such file or directory
cp: cannot stat `chroot': No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 23:46 EST by Philip Heuer
Modified: 2008-04-09 11:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 11:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of buildinstall with --debug and captured with &> (344.42 KB, text/plain)
2008-02-03 23:57 EST, Philip Heuer
no flags Details
second attempt, using idea from comment #3 (191.64 KB, text/plain)
2008-02-04 22:20 EST, Philip Heuer
no flags Details

  None (edit)
Description Philip Heuer 2008-02-03 23:46:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
The buildinstall script generates many "cp: cannot stat`chroot': No such file or directory" errors. I have traced the problem back to the upd-instroot script that buildinstall calls. I have been unable to generate an operational custom distribution DVD, possibly relating to the aforementioned errors.

Version-Release number of selected component (if applicable):
anaconda-runtime-11.3.0.50-2

How reproducible:
Always


Steps to Reproduce:
1. Generate the requisite rpm directory.
2. Run /usr/lib/anaconda-runtime/buildinstall --product Fedora --variant f8-i386-custom-local --version 8 --release "Fedora 8" --prodpath Packages {location of rpms}

Actual Results:
Many "cp: cannot stat `chroot': No such file or directory" errors appeared.

Expected Results:
The upd-instroot script should have completed without the chroot errors.

Additional info:
Comment 1 Philip Heuer 2008-02-03 23:57:01 EST
Created attachment 293859 [details]
output of buildinstall with --debug and captured with &>

In my case, the command used was:

/usr/lib/anaconda-runtime/buildinstall --debug --product Fedora --variant
f8-i386-custom-local --version 8 --release "Fedora 8" --prodpath Packages
/var/tmp/revisor-pungi/8/f8-i386-custom-local/i386/os &>
anaconda-buildinstall.log
Comment 2 Philip Heuer 2008-02-03 23:59:49 EST
From the error messages, it appears that the problem lies somewhere in the loop
that starts at line 192 in upd-instroot.
Comment 3 Joel Andres Granados 2008-02-04 05:13:49 EST
1. Kinda confused: why are you using buildinstall directly.  Why not use pungi
for the whole process?
2. If your objective is to jack the udp-instroot, I suggest you come to the
rawhide code, lots of changed have been made to the udp-instroot and things
might be a little different this time around (f9)
3. From the logs I see that there some errors where buildinstall cannot create
simlinks from /tmp to wherever you have your tree,  I'm assuming that /tmp and
the directory where you have your tree are on different partitions.  Try to do
the sam process having the temp dir and the tree dir in the same device and see
what happens.

In any case the issues regarding upd-insroot are being addressed in f9, so Im
going to close the bug as rawhide.
Comment 4 Jeroen van Meeuwen 2008-02-04 05:54:56 EST
This "solution" does not describe the actual cause of the message occuring,
could you be more specific?
Comment 5 Joel Andres Granados 2008-02-04 06:32:15 EST
Ok, lets needinfo it :) 
Now that you mention it, it might be another issue, (not the link one, of course
try it and see if it works.)  The message is caused by the upd-instroot doing
the dependency for the libraries for the initrd image (I'm pretty sure).  but
this does not cause the resulting tree to be invalid (AFAIK), its just the way
that the upd-instroot is build for f8.
Please provide info.
is the resulting tree valid?
Comment 6 Philip Heuer 2008-02-04 21:13:39 EST
In reply to comment #3 (1): I was using revisor, but the resulting DVD would not
operate properly (The boot menu loaded, but the installer never did.) Given
chroot errors were occurring during the isolinux build phase, I investigated
further. Initially, I thought that the problem was in revisor, so I added to Bug
429689 . After finding the revisor debug flag in vi, I was able to determine
that the errors were occurring during the buildinstall call. At that point I
decided to use buildinstall directly in an attempt to find the source of the
problem.

In reply to comment #3 (2): No, my goal is to create an operational custom
distribution DVD.

In reply to comment #5 : When using revisor, the installation rpm tree on the
DVD was fine. Since the installer does not load when booting from the resultant
DVD, I suspect that something is not installing properly in the boot image. As
the DVD booted, the tree is at least partially valid. Is there a good way to
check the validity of the tree?

In reply to comment #3 (3): Thanks for the thought. I will see what happens.
Comment 7 Philip Heuer 2008-02-04 22:20:43 EST
Created attachment 293968 [details]
second attempt, using idea from comment #3

I copied the f8-i386-custom-local directory (with cp -r) to /tmp and ran
buildinstall again. The command was:

/usr/lib/anaconda-runtime/buildinstall --debug --product Fedora --variant
f8-i386-custom-local --version 8 --release "Fedora 8" --prodpath Packages
/tmp/f8-i386-custom-local/i386/os &> anaconda-buildinstall.log

No chroot errors occurred this time through.
Comment 8 Philip Heuer 2008-02-06 23:00:09 EST
I tried pungi, and it seemed to build properly (it apparently works in /tmp).
The images seemed to be created properly from inspection via loopback, and the
resulting DVD booted. Now I seem to be down to some runtime errors:

1) The graphical installer does not load.
2) /usr/sbin/load_policy: can't load policy: no such file or directory
3) RuntimeError: Error running swapoff: No such file or directory

The anaconda rawhide code does seem to be significantly different, although it
is not exactly portable to Fedora 8 (I tried rebuilding the anaconda source rpm,
but there were dependency issues.) I am closer than I was in Fedora 7. Hopefully
Fedora 9 will resolve the runtime issues.
Comment 9 Joel Andres Granados 2008-02-12 07:31:59 EST
judging by the report this bug is not anaconda.  Buildinstall seem to be working
fine for the user when used directly.  It also seems to be working when used by
pungi.

Comment 10 Jeroen van Meeuwen 2008-04-07 02:34:24 EDT
You'll get the same error messages Joel, in pungi they occur as well, you just
don't see them.
Comment 11 Joel Andres Granados 2008-04-09 11:52:36 EDT
Just commited a patch that /dev/nulls some error messages from find.  Hopefully
this fixes the sed messages strangeness and the chroot strangeness.

Note You need to log in before you can comment on or make changes to this bug.