Bug 431412 - PA doesn't work with PK ... (I love all those abbreviations)
Summary: PA doesn't work with PK ... (I love all those abbreviations)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Target
TreeView+ depends on / blocked
 
Reported: 2008-02-04 10:52 UTC by Matěj Cepl
Modified: 2018-04-11 09:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 20:33:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matěj Cepl 2008-02-04 10:52:50 UTC
Description of problem:
[matej@viklef ~]$ pulseaudio --check
W: polkit.c: Failed to show grant dialog: Unable to lookup exe for caller
W: polkit.c: PolicyKit responded with 'auth_admin_keep_always'
[matej@viklef ~]$ 

Version-Release number of selected component (if applicable):
PolicyKit-0.6-1.fc8
pulseaudio-0.9.8-5.fc8

How reproducible:
100%

Steps to Reproduce:
1.run any off pulseaudio {,--check,--kill} commands, or even better pulseaudio
--realtime=true
2.
3.
  
Actual results:
see above, no PK dialog happens
pulseaudio --realtime=yet fails

Expected results:
should get lovely PK dialog asking me for password to allow realtime priority for PA

Additional info:

Comment 1 Tim Waugh 2008-02-22 17:04:32 UTC
It's because /usr/bin/pulseaudio is setuid, and so the session service
polkit-gnome-manager can't read /proc/.../exe for it.

[pid 28488] readlink("/proc/28486/exe", 0x7ffff9e59480, 4095) = -1 EACCES
(Permission denied)


Comment 2 David Zeuthen 2008-02-22 17:12:27 UTC
The bug is that PA, a daemon with no UI on it's own, calls to show auth dialogs.
This needs to happen from preference dialogs.

Comment 3 Lennart Poettering 2008-03-28 20:33:31 UTC
This has been fixed a while back in PK now. PA and PK are now perfectly
compatible again.


Note You need to log in before you can comment on or make changes to this bug.