This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 431442 - PCI passthrough fails after reboot
PCI passthrough fails after reboot
Status: CLOSED DUPLICATE of bug 233801
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 10:21 EST by Andreas Thienemann
Modified: 2009-12-14 16:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 02:31:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2008-02-04 10:21:47 EST
After rebooting a DomU guest the configured pci passthrough card has vanished:

[root@tyche ~]# uname -a
Linux tyche 2.6.18-53.el5xen #1 SMP Wed Oct 10 17:06:12 EDT 2007 i686 athlon
i386 GNU/Linux
[root@tyche ~]# lspci
00:00.0 Communication controller: Cyclades Corporation Cyclades-Z above first
megabyte (rev 01)
[root@tyche ~]# reboot

Broadcast message from root (pts/1) (Mon Feb  4 16:15:24 2008):

The system is going down for reboot NOW!
[root@tyche ~]# rebootConnection to tyche closed by remote host.
Connection to tyche closed.
[athienem@localhost ~]$ ssh root@tyche
Last login: Mon Feb  4 16:13:14 2008 from nat-pool-str.redhat.com
[root@tyche ~]# lspci
[root@tyche ~]# 

shutting down the guest, waiting and starting it again makes the pci device work
again.
No messages about pci stuff in dmesg.
Comment 1 Andreas Thienemann 2008-02-19 02:31:47 EST

*** This bug has been marked as a duplicate of 233801 ***

Note You need to log in before you can comment on or make changes to this bug.