Bug 431467 - Failing incremental backup based only on the signatures
Failing incremental backup based only on the signatures
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: duplicity (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 14:30 EST by Jan Kratochvil
Modified: 2008-02-13 00:12 EST (History)
0 users

See Also:
Fixed In Version: 0.4.9-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 23:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-02-04 14:30:12 EST
Description of problem:
During remote backup storage I would like to have locally only the signatures,
create incremental backup files locally and upload them myself (by rsync).
Fedora duplicity refuses it with:
  Found signatures but no corresponding backup files

Version-Release number of selected component (if applicable):
duplicity-0.4.3-1.fc8.x86_64

How reproducible:
Always.

Steps to Reproduce:
#! /bin/sh
set -ex
rm -rf signatures files backup1 backup2
mkdir signatures
mkdir files
echo file1 >files/file1
# No signatures found, switching to full backup.
duplicity --archive-dir ./signatures ./files file://$PWD/backup1
rm -f files/file1
echo file2 >files/file2
# Found signatures but no corresponding backup files
# vs.
# Warning, found signatures but no corresponding backup files
duplicity --archive-dir ./signatures ./files file://$PWD/backup2
echo OK

Actual results:
+ rm -rf signatures files backup1 backup2
+ mkdir signatures
+ mkdir files
+ echo file1
+ duplicity --archive-dir ./signatures ./files file:///tmp/duptest/backup1
No signatures found, switching to full backup.
./signatures/tmpGzdzb8 still in tempfile list, deleting
./signatures/tmp4nzsJ8 still in tempfile list, deleting
GnuPG passphrase:
Retype to confirm:
--------------[ Backup Statistics ]--------------
StartTime 1202150968.34 (Mon Feb  4 19:49:28 2008)
EndTime 1202150968.34 (Mon Feb  4 19:49:28 2008)
ElapsedTime 0.00 (0.00 seconds)
SourceFiles 2
SourceFileSize 4102 (4.01 KB)
NewFiles 2
NewFileSize 4102 (4.01 KB)
DeletedFiles 0
ChangedFiles 0
ChangedFileSize 0 (0 bytes)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 2
RawDeltaSize 6 (6 bytes)
TotalDestinationSizeChange 489 (489 bytes)
Errors 0
-------------------------------------------------

+ rm -f files/file1
+ echo file2
+ duplicity --archive-dir ./signatures ./files file:///tmp/duptest/backup2
Found signatures but no corresponding backup files



Expected results:
TotalDestinationSizeChange 491 (491 bytes)
Errors 0
-------------------------------------------------

+ rm -f files/file1
+ echo file2 
+ duplicity --archive-dir ./signatures ./files file:///tmp/duptest/backup2
Warning, found signatures but no corresponding backup files
No signatures found, switching to full backup.
GnuPG passphrase:
Retype to confirm: 
--------------[ Backup Statistics ]--------------
StartTime 1202150999.22 (Mon Feb  4 19:49:59 2008)
EndTime 1202150999.23 (Mon Feb  4 19:49:59 2008)
ElapsedTime 0.01 (0.01 seconds)
SourceFiles 2
SourceFileSize 4102 (4.01 KB)
NewFiles 2
NewFileSize 4102 (4.01 KB)
DeletedFiles 0
ChangedFiles 0
ChangedFileSize 0 (0 bytes)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 2
RawDeltaSize 6 (6 bytes)
TotalDestinationSizeChange 491 (491 bytes)
Errors 0
-------------------------------------------------

+ echo OK
OK

Additional info:
It works with the upstream version:
http://savannah.nongnu.org/download/duplicity/duplicity-0.4.9-0.fdr.6.src.rpm
The `Expected results' log was created with the upstream version.
Comment 1 Robert Scheck 2008-02-04 15:38:33 EST
Jan, 0.4.9 is a problem for me, because there were really HUGE changes which 
are causing also command line incompatibilities. Suggestions?
Comment 2 Jan Kratochvil 2008-02-04 15:47:00 EST
OK, fine to close with RAWHIDE and build the upstream version into Rawhide; F9
is pretty close.
Thanks for the serious care of the backward compatibility. :-)
Comment 3 Fedora Update System 2008-02-10 12:17:43 EST
duplicity-0.4.9-1.fc7 has been submitted as an update for Fedora 7
Comment 4 Fedora Update System 2008-02-10 12:17:45 EST
duplicity-0.4.9-1.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-02-12 23:59:52 EST
duplicity-0.4.9-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-02-13 00:12:26 EST
duplicity-0.4.9-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.