Bug 43147 - ImageMagick should depend on ghostscript
Summary: ImageMagick should depend on ghostscript
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-01 12:07 UTC by Reuben Thomas
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 12:07:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Reuben Thomas 2001-06-01 12:07:09 UTC
Description of Problem:

The convert program uses /usr/bin/gs to convert PostScript files, yet the 
ImageMagick RPM has no dependency on ghostscript (at least, it's not mentioned 
in rpm -q --requires ImageMagick).

How Reproducible:

Every time

Steps to Reproduce:
1. Install ImageMagick but not ghostscript
2. Try to convert a PostScript file
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Bernhard Rosenkraenzer 2001-06-01 12:29:38 UTC
Since RPM doesn't have a "RequiresForFullFunctionalityButWorksWithout:" tag, 
and ImageMagick can be quite useful without PostScript support (e.g. for 
converting gifs to pngs), I prefer having it the way it is.



Note You need to log in before you can comment on or make changes to this bug.