Bug 43148 - BAD: Module doesn't work for the 21040 NIC
BAD: Module doesn't work for the 21040 NIC
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 08:21 EDT by Kim Futtrup Petersen
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 09:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Futtrup Petersen 2001-06-01 08:21:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
The RedHat startup-script says it initializes eth0 fine but this is NOT 
true. The driver/module for the DEC 21040 / Tulip network adapter
is BROKEN on RedHat 7.1. The card looses the connection to the hub/switch 
when it's initialized by the start-up script.

How reproducible:
Always

Steps to Reproduce:
1.Boot with the 21040 adapter in the machine
2.Do ifdown eth0 to down the network adapter
3.Do ifup eth0 and it fails to load the module.
	

Actual Results:  Nothing - which is the problem ;) My network adapter 
still doesn't work.

Expected Results:  The module should have loaded and networking worked.

Additional info:

It's pretty bad that anaconda / the installer finds and configures the 
network adapter at installation time, but the card doesn't work.
Comment 1 Pekka Savola 2001-07-22 15:28:43 EDT
This is related to drivers, changing to kernel component.

This might also be a local configuration issue; check:
 1) dmesg output when loading the driver
 2) whether your switch is using autonegotiation (probably yes); if not, you need to tune /etc/modules.conf
 3) 'lspci' output; which driver is used?
 4) 'mii-tool -v'.
Comment 2 Arjan van de Ven 2001-07-22 15:33:07 EDT
Also, does the de4x5 driver work instead of the tulip driver work ?
Comment 3 Alan Cox 2003-06-06 09:07:54 EDT
Closed: Inactive

Note You need to log in before you can comment on or make changes to this bug.