Bug 43152 - Automatic partitioning creates wastefully large /boot on big HDs
Automatic partitioning creates wastefully large /boot on big HDs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 09:57 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 16:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-01 09:57:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.5 i686; Nav)

Description of problem:
I have a 40 GB hard-disk. The automatic partitioning created a 50 MB /boot
partition. 15 MB were more than enough for me at all times, ever since I
use Red Hat, and having 3 or 4 alternative kernels on it left more than
half of those 15 MB unused. It's not that I'll die because of the wasted 35
MB, but it's pointless to have such a big /boot. Wasting resources like
that is the Windows way, not linux'.

How reproducible:
Always

Steps to Reproduce:
Choose automatic partitioning.

Actual Results:  Too large /boot (probably creates it using a disk
percentage formula)

Expected Results:  15 MB fixed size for all hard-disks

Additional info:
Comment 1 Brent Fox 2001-06-01 16:35:38 EDT
I think it's better to err on the side of having too much room than too little.
 Maybe 15MB is enough for you, but you can't really take that and then say that
should apply to everybody.  If the user runs out of space and really needs it
one day, then they are kind of stuck.
Also, there are other things to consider.  Some people install GRUB and use that
as the bootloader.  Grub installs itself into the /boot/grub directory, so that
takes up space.  Also, on other architectures, kernels take up more space than
on x86.  For example, on Itanium systems, the kernels are over twice as big as
on x86, plus the configuration files for the elilo boot loader is stored in the
/boot directory too.  We don't want to conditionalize the installer to change
it's size for the /boot partition based on architecture.  
You can always create the partitions manually if 50MB is too big for you.  It's
too big for me, personally, so I make my /boot 25MB.

Note You need to log in before you can comment on or make changes to this bug.