Bug 43154 - "swapon -a" reports device busy if run second time
Summary: "swapon -a" reports device busy if run second time
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-01 14:36 UTC by Pavel Roskin
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 14:36:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Roskin 2001-06-01 14:36:10 UTC
Description of Problem:

"man swapon" says:
-a All devices marked as ``sw'' swap devices in /etc/fstab are made 
available. Devices that are already running as swap are silently skipped.

However, they are _not_ silently skipped:

# /sbin/swapon -a
swapon: /dev/hde6: Device or resource busy

Since /etc/rc.d/rc.sysinit runs swapon twice, the second time it causes 
unpleasant error messages during startup.

How Reproducible:

Every time.

Steps to Reproduce:
1. Install RedHat 7.1 with a swap partition and without swap files.
2. Boot it.

Actual Results:

An error message appears after "Enabling swap space", followed by [Ok]

Expected Results:

No error message. Actually, "Enabling swap space" is useless too, but 
it's another story.

Additional Information:

Update to mount-2.11b-3 doesn't fix the problem.

Comment 1 Bernhard Rosenkraenzer 2002-01-17 19:30:14 UTC
This was fixed in 7.2.


Note You need to log in before you can comment on or make changes to this bug.