Bug 431560 - Circular build dependency
Circular build dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-PPI (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 09:21 EST by Ed Avis
Modified: 2008-03-11 21:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 21:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-02-05 09:21:34 EST
Building perl-PPI needs perl-Test-ClassAPI.
Building perl-Test-ClassAPI needs perl-Class-Inspector.
Building perl-Class-Inspector needs perl-Test-MinimumVersion.
Building perl-Test-MinimumVersion needs perl-Perl-MinimumVersion.
Building perl-Perl-MinimumVersion needs perl-PPI.

Since PPI doesn't really need Test::ClassAPI but only uses it in one part of its
test suite, I suggest breaking that BuildRequires dependency.

(If Test::ClassAPI is not installed then the test suite passes anyway, since it
skips that one test.)
Comment 1 Tom "spot" Callaway 2008-03-11 21:05:19 EDT
Yes, this is a loop, but its only a problem when doing mass rebuilds for base
perl version changes. I'd rather have the full test functionality for the normal
case.

Note You need to log in before you can comment on or make changes to this bug.