Bug 431571 - Blender does not load yafray plugin on x86_64
Blender does not load yafray plugin on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 10:22 EST by Richard Smith
Modified: 2008-03-11 06:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 06:36:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch blender yafray plugin and library paths to lib64 versions (539 bytes, patch)
2008-02-05 10:22 EST, Richard Smith
no flags Details | Diff

  None (edit)
Description Richard Smith 2008-02-05 10:22:48 EST
Description of problem:

Hardcoded library paths in blender source point to /usr/lib and /usr/lib/yafray
which is not where the 64 bit plugin is installed on x86_64.

Version-Release number of selected component (if applicable):

Latest version of blender 2.45-4 on Fedora 8 and Fedora 7.

How reproducible:
Always

Steps to Reproduce:
1. Start blender from a console window
2. Select yafray as renderer and uncheck the xml option
3. Console window displays a message saying the plugin was not found
  
Actual results:
Black render window appears.  This is not a lighting issue, as it works fine
when using the xml option.

Expected results:
Rendered image of the default scene.

Additional info:
The problem is that blender is looking in the wrong directories for the plugin
and its associated libraries.

Patch attached which fixes the problem. Could be included in spec file with
something like:

Patch3:         blender-2.45-x86_64.patch

 ...

%ifarch x86_64
%patch3 -p1 -b .orig
%endif
Comment 1 Richard Smith 2008-02-05 10:22:48 EST
Created attachment 294002 [details]
Patch blender yafray plugin and library paths to lib64 versions
Comment 2 Richard Smith 2008-02-22 07:31:59 EST
Just a quick note to say that this bug has now been fixed in the upstream
subversion repository.  Thus the next version (2.46?) should not have this bug
when it gets released around April / May.
Comment 3 Jochen Schmitt 2008-02-29 06:48:46 EST
Thank your for reporting this bug and offering the patch.

I have create updates for rawhide, F-8 and F-7
Comment 4 Nicolas Chauvet (kwizart) 2008-02-29 14:18:55 EST
@Richard
Which is the yafray version and release you have installed ?
Is it an updated version from the (fedora) updates reposity ?
Comment 5 Nicolas Chauvet (kwizart) 2008-03-04 10:49:28 EST
?
Comment 6 Nicolas Chauvet (kwizart) 2008-03-04 11:07:25 EST
I confirm that the updates breaks yafray rendering on 32bit systems (preventing
to use /usr/lib/libyafrayplugin.so with xml parser disabled .)

The error is:
Error loading yafray plugin /usr/lib/blender.bin : undefined symbol: getYafray
(where the symbol exist in /usr/lib/libyafrayplugin.so).

Please apply this patch conditionally using:
%if %{?_lib} == "lib64"
%pactchX
%endif

Comment 7 Nicolas Chauvet (kwizart) 2008-03-05 06:36:56 EST
Thx for fixing it Jochen, it should be fine now.

Comment 8 Richard Smith 2008-03-11 06:50:49 EDT
Apologies for the delay in replying, I have been away for a couple of weeks.

Re: Comment #4
I have yafray-0.0.9-5 installed on both the F7 and F8 machines.

I have just installed blender-2.45-9 from updates-testing and it appears to work
correctly on F8 x86_64.  Thanks for the fix.

Note You need to log in before you can comment on or make changes to this bug.