Bug 431577 - Build fails depending on current locale
Summary: Build fails depending on current locale
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Perl-Critic   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-05 16:23 UTC by Ed Avis
Modified: 2008-07-01 03:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 03:48:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Avis 2008-02-05 16:23:03 UTC
Building perl-Perl-Critic from the source package fails if your locale is not
en_US.  Fix it by changing line 66 of the spec file to

LC_ALL=en_US.UTF-8 TEST_AUTHOR=1 ./Build test

However, I think you should consider turning off TEST_AUTHOR; it is intended for
the author's own tests, after all.  Newer versions of Perl::Critic on CPAN fail
some author tests.

Comment 1 Chris Weyl 2008-07-01 03:48:02 UTC
Fixed in rawhide (dropped author tests), package building now.  Will push out to
F-8, F-9, as the occasion arises.


Note You need to log in before you can comment on or make changes to this bug.