Bug 431599 - please update Lout to version 3.36
please update Lout to version 3.36
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lout (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 15:01 EST by Vadim Nasardinov
Modified: 2008-03-13 03:47 EDT (History)
0 users

See Also:
Fixed In Version: 3.36-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
updated spec file (3.38 KB, text/plain)
2008-02-05 15:01 EST, Vadim Nasardinov
no flags Details
a two-line patch file against Lout's makefile (819 bytes, patch)
2008-02-05 15:03 EST, Vadim Nasardinov
no flags Details | Diff

  None (edit)
Description Vadim Nasardinov 2008-02-05 15:01:55 EST
First off, thanks for shipping Lout in Fedora.


Could you please update it to the latest upstream version?  Fedora has
been shipping lout-3.30 for the past two and a half years.  The latest
upstream version is lout-3.36.tar.gz, made available on the Lout
author's FTP site on Jul 27, 2007:

  ftp://ftp.cs.usyd.edu.au/jeff/lout/
  ftp://ftp.it.usyd.edu.au/jeff/lout/

Compared to the version shipped in F8, the latest Lout has six minor
releases' worth of bugfixes.

Another problem with the current Fedora RPM is that it ships an
ancient copy of the Lout User Guide.  The User Guide is even older
than the lout executable.  Lout 3.30 was released on Aug 24, 2005, but
the User Guide included in lout-3.30-7.fc8.src.rpm is for Lout 3.24
released on Oct 8, 2000.



The attached spec file is based on lout-3.30-7.fc8.src.rpm.  I made
the following changes:


 1. Bumped the version number from 3.30 to 3.36.

 2. Changed the URL from
       http://lout.sourceforge.net/
    to
       ftp://ftp.cs.usyd.edu.au/jeff/lout/

    The Sourceforce project is merely a mirror of Jeff Kingston's FTP
    directory.

 3. Reworked the patch file substantially.  The new patchfile only
    modifies two lines of the original makefile.

 4. I added a few additional steps to the build section to generate
    documentation.  The Lout source tarball ships lout-formatted
    sources for the following four documents:

     (a) The Design and Implementation of the Lout Document Formatting
         Language

     (b) A Practical Introduction to the Lout Document Formatting
         System

     (c) A User's Guide to the Lout Document Formatting System

     (d) An Expert's Guide to the Lout Document Formatting System

    In addition to the plain-text lout source files for these docs,
    the tarball also includes prebuilt Postcript versions of (a), (b),
    and (d).  All three of these are named outfile.ps.

    The Postscript version of the User Guide is not included in the
    main tarball but is available as a separate gzipped Postscript
    file both from Jeff's FTP site and from the Sourceforge mirror
    thereof:

      http://sourceforge.net/projects/lout

    However, since these Postscript files can be generated by lout
    itself from the plain-text files included in the tarball, I have
    added the necessary logic to the spec file to produce PDF
    versions.  The steps are:

       (i) Build lout.  (We need this regardless.)

      (ii) Use the freshly built lout to generate Postscript versions.

     (iii) Use Ghostscript's /usr/bin/ps2pdf14 to convert Postscript
           versions into more compact PDF versions.

 5. My decision to replace prebuilt Postscript files with freshly
    generated PDFs introduced a build dependency on ghostscript.

 6. I removed the build dependency on zlib.

    The story here is that, in theory, Lout is capabable of rendering
    lout-formatted text files into three outputs:

      (a) "typeset" plain text;

      (b) Postscript

      (c) PDF

    Lout generates PDF by emitting PDF code directly.  However, as
    Lout's READMEPDF tells us, the PDF backend is incomplete.  Jeff
    Kingston has no intention of bringing it on par with the
    Postscript backend.  In fact, if you try to render Lout's own
    documentation in PDF using lout's -PDF option, you'll find that it
    doesn't work.

    So, since PDF generation does not work, it seems silly to provide
    non-working *compressed* PDF generation capability by linking
    (dynamically) against zlib.

    For Windows users, disabling PDF compression may be viewed as a
    loss of functionality.  For Fedora users, no such loss occurs.  If
    you need PDF output, you can generate Postscript first and then
    convert it to PDF using Ghostscript.


Size-wise, things have changed as follows.

Old RPM:

  1.9M    lout-3.30.tar.gz
  2.5M    lout-3.30-7.fc8.src.rpm
  2.9M    lout-3.30-7.fc8.x86_64.rpm

New RPM:

  2.1M    lout-3.36.tar.gz
  2.1M    lout-3.36-1.fc7.src.rpm
  3.3M    lout-3.36-1.fc7.x86_64.rpm
Comment 1 Vadim Nasardinov 2008-02-05 15:01:55 EST
Created attachment 294038 [details]
updated spec file
Comment 2 Vadim Nasardinov 2008-02-05 15:03:19 EST
Created attachment 294039 [details]
a two-line patch file against Lout's makefile

This goes with the above spec file.
Comment 3 Tom "spot" Callaway 2008-02-19 17:16:30 EST
Wow, thanks for the great work here! I've integrated it into CVS, and built for
F-7, F-8, devel, and EL-5 (EL-4 failed, but it is so ancient, I'm not sure it is
worth fixing at this point).
Comment 4 Fedora Update System 2008-02-19 17:19:25 EST
lout-3.36-1.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-02-19 17:20:09 EST
lout-3.36-1.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-02-20 21:53:48 EST
lout-3.36-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lout'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1858
Comment 7 Fedora Update System 2008-03-13 03:41:30 EDT
lout-3.36-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-03-13 03:47:45 EDT
lout-3.36-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.