Bug 431623 - NFS hanging on rpc.idmapd error
NFS hanging on rpc.idmapd error
Status: CLOSED DUPLICATE of bug 405711
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.1
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 19:06 EST by Garrett
Modified: 2008-09-18 16:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 16:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett 2008-02-05 19:06:47 EST
Description of problem:

I have a new 64-bit RHEL5.1 server connected to two RAIDs via fiber, and a
network of 32-bit Fedora 7 workstations. We use a separate Fedora Directory
server to handle the authentication. This was all working until we installed the
new RAID and file server.
  Periodically the NFS will freeze. Checking the log I will see:

rpc.idmapd: nfsdcb: id '-2' too big! 

  When I see that, no new NFS connection will happen, and the existing ones will
freeze within a few minutes.

  Here's my /etc/exports:

/export
192.168.1.0/24(ro,fsid=0,insecure,no_subtree_check,sync,anonuid=65534,anongid=65534)
/export/d0
192.168.1.0/24(rw,fsid=1,nohide,insecure,no_subtree_check,anonuid=65534,anongid=65534)
/export/d1
192.168.1.0/24(rw,fsid=2,nohide,insecure,no_subtree_check,anonuid=65534,anongid=65534)

  We are using autofs to mount the drives. Here the file:

d0      -rw,fstype=nfs4,bg,soft,intr,noatime,proto=tcp   192.168.1.8:/d0
d1      -rw,fstype=nfs4,bg,soft,intr,noatime,proto=tcp   192.168.1.8:/d1

  And lastly, here's the idmapd.conf file:

[General]

Verbosity = 3 
Pipefs-Directory = /var/lib/nfs/rpc_pipefs
Domain = berkeley.edu

[Mapping]

Nobody-User = nfsnobody
Nobody-Group = nfsnobody

[Translation]
Method = nsswitch

Version-Release number of selected component (if applicable):


How reproducible:

  Sometimes it takes a few hours for this to happen. Other times it happens
almost immediately after restarting NFS.

Steps to Reproduce:
1.
2.
3.
  
Actual result:
NFS freezes.

Expected results:
It works.

Additional info:

  We read the ticket id=225507 and it didn't solve the problem.
Comment 1 Jukka Lehtonen 2008-02-07 03:46:57 EST
Similar observation:
* Server CentOS 5.1; 2.6.18-53.1.4.el5.x86_64
* Client Fedora 7; 2.6.23.12-52.fc7.i386
* XFS partition shared via NFSv4, auth=sys
* nfsnobody uid=65534

1. On client: # du -shc /path as valid user
=> on server: rpc.idmapd: nfsdcb: id '-2' too big!
=> NFS freeze
=> server rebooted

2. On client: # rm -fr /path as valid user
=> on server: rpc.idmapd: nfsdcb: id '-2' too big!
=> NFS freeze
=> server rebooted
Comment 2 Garrett 2008-02-11 13:39:16 EST
I got it fixed...in a way.
  What we did was wipe the hard drive and downgrade to the 32-bit version of RHEL 5.
   We no longer have those errors now. Why they occurred in the 64-bit version I
couldn't tell you.
Comment 3 RHEL Product and Program Management 2008-06-02 16:19:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Steve Dickson 2008-09-18 16:15:36 EDT

*** This bug has been marked as a duplicate of bug 405711 ***

Note You need to log in before you can comment on or make changes to this bug.