Bug 431648 - rhn-virtualization-common needs to be in Base
rhn-virtualization-common needs to be in Base
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.1
All Linux
medium Severity low
: rc
: ---
Assigned To: Dennis Gregorovic
: FutureFeature
Depends On:
Blocks: RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-02-06 00:33 EST by Marco Grigull
Modified: 2008-11-18 19:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
(all architectures) When provisioning guests during installation, the RHN tools for guests option will not be available. When this occurs, the system will require an additional entitlement, separate from the entitlement used by dom0. To prevent the consumption of additional entitlements for guests, install the rhn-virtualization-common package manually before attempting to register the system to Red Hat Network.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 14:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Grigull 2008-02-06 00:33:52 EST
Description of problem:
PV guests install with method other than KS, then have to use standard entitlment

Version-Release number of selected component (if applicable):
rhn-virtualization-common (all versions)

How reproducible:
install PV guest without using KS.  Register system and notice that it is not
associated to host in RHN

Steps to Reproduce:
1. Setup nfs/http/ftp install set from base channel content or release cdrom
2. configure PV guest for install without using KS
3. Follow prompts to connect to RHN for updates ....
  
Actual results:
System requires standalone entitlement

Expected results:
System should use Hosts entitlement where available

Additional info:
https://rhn.redhat.com/network/software/packages/details.pxt?pid=409066 before
entitling.  However, this package is part of RHN tools for guests and is not
available on cdrom or before entitling with standard entitlement.  This package
should be part of the Base so that it can be made use of in these situations. 
RHEL4 dpoes not seem to have acces to this package.  This package provides
optional access to xen information exsposed by the host to the guest for RHN
purposes.

This can be avoided by adding package rhn-virtualization-common this only helps
rhel5 installs.
Comment 1 Marco Grigull 2008-04-24 21:33:05 EDT
release notes:
when provisoning guests AND 'RHN tools for guests' channel is not available
during the install, the system will aquire a unique entitlement seperate from
the entitlement that the host utilises.  In order to prevent consumption of
additional entitlements, the package 'rhn-virtualization-common' will have to be
manually aquired and installed _before_ attempting to register the system to RHN.

side notes:
there are numerous conditions that prevent the extra channel from being
available during the install.  Having 'rhn-virtualization-common' in the base
channel would avoid this issue.
Comment 2 Don Domingo 2008-04-27 21:51:11 EDT
thanks Marco, revising as follows;

<quote>
      When provisioning guests during installation, the RHN tools for guests
option will not be available. When this occurs, the system will require an
additional entitlement, separate from the entitlement used by dom0.

      To prevent the consumption of additional entitlements for guests, install
the rhn-virtualization-common package manually before attempting to register the
system to Red Hat Network.
</quote>

please advise if any further revisions are required. thanks!
Comment 4 RHEL Product and Program Management 2008-07-17 14:41:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Clifford Perry 2008-07-30 09:26:40 EDT
From comment #1:

Description of problem:
PV guests install with method other than KS, then have to use standard entitlment

How reproducible:
install PV guest without using KS.  Register system and notice that it is not
associated to host in RHN

Actual results:
System requires standalone entitlement

Expected results:
System should use Hosts entitlement where available


Issue here - 
I have a Xen Host RHEL 5 Server and creating guests on it, Para-Virt guests,
RHEL 4.5 or newer RHEL 5.0 and newer. When I go to register these guests to RHN
I see two issues:
1 - they do not show up as being associated with the Xen Host server that is
also registered to my RHN account
2 - they consume a full regular entitlement and not piggy back under the Xen
hosts entitlement 

The proposed solution is to install 'rhn-virtualization-common' onto your PV
guest in the believe that this will fix the issue. This is incorrect. The Xen
Host is what sends up the information - the PV will not consume entitlements if
the Xen Host system registered to RHN is correctly entitled & has the software
we schedule for installation done. 

So, take this situation - say ISO installation:
Xen Host - I register to RHN 
PV Guest - I register to RHN 
both consume entitlements. Both systems due to type of kernel installed (and no
rhn-virtualization-common package installed on either) are correctly shown in
RHN as being Xen Host or Xen Guest systems but have no association to each other. 

Now login to RHN and give your Xen host a Virtualization Entitlement. The act of
giving your Host Virtualization entitlement results in the following things
happening:
- Virtualization Entitlement added to system
- Automatic subscription to the RHN Tools child channel 
- Automatic subscription to the RHEL Virtualization child channel
- schedule of package install onto system of package rhn-virtualization-host

On the Xen Host you then type: rhn_check -vv and it installs this package, one
line of output is:

Adding packages to package profile: ['rhn-virtualization-host-1.0.1-55',
'rhn-virtualization-common-1.0.1-55']

this installation also sets up a regular cron job task to run every 2 minutes to
report back state of guests known about and if things have changed (only reports
back when something changed to previous cached data -
/var/cache/rhn/virt_state.cache). 

This sends up a listing of uuid running on the Xen Host to RHN. RHN then joins
these uuid's to their associated PV guests already registered to RHN and display
them as such within RHN. It will also automatically change the Management
entitlement being used on the PV guest to be a non-consuming entitlement and
free up one more management entitlement on the account. 

So, this is in a nut shell how the Virtualization Entitlement and associated
tools were designed to work. (lots more info on our wiki pages -
http://wiki.rhndev.redhat.com/wiki/Special:Search?search=virtualization&go=Go)

I do not see the benefit for PV guest installations of making the
rhn-virtualization-common package part of the base distro, since as in the
above, we do not need, nor install it on PV guests for the virtualization
entitlement model to work. 

Cliff. 



Comment 10 Ryan Lerch 2008-08-06 22:40:57 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes.
Comment 11 Ryan Lerch 2008-08-06 22:40:57 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 12 Dennis Gregorovic 2008-08-07 14:15:29 EDT
Based on comment #9, closing NOTABUG.  Release Note addition has been added.

Note You need to log in before you can comment on or make changes to this bug.