Bug 43172 - Kernel panic when system boots, can't mount root filesystem.
Kernel panic when system boots, can't mount root filesystem.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 14:44 EDT by Kevin Stansell
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 11:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initrd (677.97 KB, application/octet-stream)
2001-06-05 15:35 EDT, Kevin Stansell
no flags Details

  None (edit)
Description Kevin Stansell 2001-06-01 14:44:09 EDT
Description of Problem:
When booting into the system with the command 'elilo linux' a kernel panic occurs.  This only happens with qa0529-ia64-disc1.iso.  The previous release worked fine.  The problem seems to be in the elilo.conf file, the ram disk will never get called correctly due to question marks corrupting the file.  Once taken out the system boots up properly with no kernel panic.

How Reproducible:
Every time

Steps to Reproduce:
1. Install Redhat IA64 qa0529-ia64 on a SCSI based system
2. Run elilo linux to boot the system
3. Kernel panic will occur, syaing root filesystem could not be mounted.
	

Actual Results:
Kernel Panic occured.

Expected Results:
System should boot properly as with previous releases.

Additional Information:
Comment 1 Bill Nottingham 2001-06-01 16:46:28 EDT
Can you post the elilo.conf created?
Comment 2 Kevin Stansell 2001-06-04 13:20:16 EDT
Here is the elilo.conf that is created:

timeout=50

image=vmlinuz-2.4.3-2.10.1smp
?label=linux
?initrd=initrd-2.4.3-2.10.1smp.img
?read-only
?root=/dev/sda5

image=vmlinuz-2.4.3-2.10.1
?label=linux-up
?initrd=initrd-2.4.3-2.10.1.img
?read-only
?root=/dev/sda5

Comment 3 Bill Nottingham 2001-06-04 14:24:32 EDT
Is this root-on-raid?
Comment 4 Bill Nottingham 2001-06-04 14:24:56 EDT
Never mind that. I need to learn to read. :).

Can you post the initrd?
Comment 5 Kevin Stansell 2001-06-05 15:35:35 EDT
Created attachment 20352 [details]
initrd
Comment 6 Kevin Stansell 2001-06-06 14:00:03 EDT
A new cut of the ia64 was downloaded and is giving the following error during 
installation:

"An error occurred tring to format /.  This problem is serious, and the install 
cannot continue. Press Enter to reboot the system."

This occurs right before the packages are to be installed.

Comment 7 Kevin Stansell 2001-06-06 15:14:18 EDT
Here are the specifications:

1. Server machine
2. Qlogic QLA1216x
      driver loaded - qla1280
3. sda:  71722776 512-byte hdwr sectors (36722 MB)
   sdb:  71722776 512-byte hdwr sectors (36722 MB)
4. Partitions:
   /boot/efi    sda1    150M     Dos 16-bit>=32M 
   <Swap>       sda2    2047M   
   /            sda3    Use remaining free space       Linux Native

5. The drivers had the qa0529 cut of Red-hat on them before installation.

The qa0529 was tried again after this error occured and it installed fine. The 
only problem was the kernel panic as stated previously.  This error occurs only 
with the qa0605 cut.
Comment 8 Bill Nottingham 2001-06-07 14:30:36 EDT
The second issue should be fixed in anaconda-7.1-15 or later.

The first issue we still can't reproduce here. Can you post the
exact errors after it loads the qla1280 module from the initrd?
Comment 9 Kevin Stansell 2001-06-12 11:19:45 EDT
Both issues resolved in qa0611.

Note You need to log in before you can comment on or make changes to this bug.